summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2021-12-09 09:28:43 +0800
committerButui Hu2021-12-09 09:28:43 +0800
commit68c26ffc0f44c1fe02558bbb17d987e004b8ad3d (patch)
tree76b126f57e39550de26cf89aa54ff5f59ca584aa
downloadaur-68c26ffc0f44c1fe02558bbb17d987e004b8ad3d.tar.gz
first commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c2760fedcb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-simplecrf
+ pkgdesc = Python wrap of crf and dense crf, both 2d and 3d are supported
+ pkgver = 0.2.1.1
+ pkgrel = 1
+ url = https://github.com/HiLab-git/SimpleCRF
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-numpy
+ source = python-simplecrf-0.2.1.1.tar.gz::https://github.com/HiLab-git/SimpleCRF/archive/refs/tags/v0.2.1.1.tar.gz
+ sha512sums = e8cac6be6b4a0eec80d015014a4ec0b960503f59e01f3f45f4a147ab8e51f1d161ee6e3b23f74242f26896bdd43a8c35c7107b7d4c5c1aa281d1b8ec5c0664e7
+
+pkgname = python-simplecrf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f3ff8fb6131
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+pkgname=python-simplecrf
+_pkgname=SimpleCRF
+pkgver=0.2.1.1
+pkgrel=1
+pkgdesc='Python wrap of crf and dense crf, both 2d and 3d are supported'
+arch=('x86_64')
+url='https://github.com/HiLab-git/SimpleCRF'
+license=('BSD')
+depends=(
+ python-numpy
+)
+makedepends=(
+ python-setuptools
+)
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/HiLab-git/SimpleCRF/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('e8cac6be6b4a0eec80d015014a4ec0b960503f59e01f3f45f4a147ab8e51f1d161ee6e3b23f74242f26896bdd43a8c35c7107b7d4c5c1aa281d1b8ec5c0664e7')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: