summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-04-24 12:52:03 +0200
committerMartino Pilia2018-04-24 12:52:03 +0200
commit94107dbda7bc79c0e41ba21b1cde3491a378950f (patch)
treeda60f95ab18598d3266fa7e73b6a778d64149d1a
downloadaur-94107dbda7bc79c0e41ba21b1cde3491a378950f.tar.gz
package submission
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..781338f97b61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-simpleitk
+ pkgdesc = Simplified layer built on top of ITK
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://simpleitk.org/
+ arch = x86_64
+ license = apache
+ makedepends = python-pip
+ depends = python
+ conflicts = simpleitk
+ options = !strip
+ source = https://files.pythonhosted.org/packages/cp36/S/SimpleITK/SimpleITK-1.1.0-cp36-cp36m-manylinux1_x86_64.whl
+ sha256sums = 9077301b0a91d93613588201e03de70b00736f97c542d0a04527ef8f1c78a53a
+
+pkgname = python-simpleitk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c22ea2932a13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+_name=SimpleITK
+_py=cp36
+pkgname=python-simpleitk
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Simplified layer built on top of ITK'
+arch=('x86_64')
+url='https://simpleitk.org/'
+license=('apache')
+depends=('python')
+conflicts=('simpleitk')
+makedepends=('python-pip')
+options=('!strip')
+optdepends=()
+source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name/-/_}-$pkgver-$_py-${_py}m-manylinux1_x86_64.whl")
+sha256sums=('9077301b0a91d93613588201e03de70b00736f97c542d0a04527ef8f1c78a53a')
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/SimpleITK"
+}
+