summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:28:35 -0700
committerAaron DeVore2015-07-08 11:28:35 -0700
commiteedfaa2c0042f8096b2797fbd6da01bbce94a650 (patch)
treeebba13fc74c2e5b524329989dd9ce392c0054501
downloadaur-eedfaa2c0042f8096b2797fbd6da01bbce94a650.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f256cb762c5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-simpletal
+ pkgdesc = Standalone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates.
+ pkgver = 5.1
+ pkgrel = 1
+ url = http://www.owlfish.com/software/simpleTAL/
+ arch = any
+ license = BSD
+ depends = python
+ source = http://www.owlfish.com/software/simpleTAL/downloads/SimpleTAL-5.1.tar.gz
+ md5sums = 2c43fb2376d501c2957bda26c81c419f
+
+pkgname = python-simpletal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6bcb369e936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Alper KANAT <alperkanat@raptiye.org>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+
+pkgname=python-simpletal
+pkgver=5.1
+pkgrel=1
+pkgdesc='Standalone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates.'
+arch=('any')
+url='http://www.owlfish.com/software/simpleTAL/'
+license=('BSD')
+depends=('python')
+source=("http://www.owlfish.com/software/simpleTAL/downloads/SimpleTAL-${pkgver}.tar.gz")
+md5sums=('2c43fb2376d501c2957bda26c81c419f')
+
+build() {
+ cd SimpleTAL-${pkgver}
+
+ python setup.py build
+}
+
+package() {
+ cd SimpleTAL-${pkgver}
+
+ python setup.py install --root=${pkgdir} --optimize=1
+
+ install -D -m644 ${srcdir}/SimpleTAL-${pkgver}/LICENSE.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/license
+}