summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-12-29 17:48:59 +0800
committerUniversebenzene2021-12-29 17:48:59 +0800
commit78b05fe670f5ea8c153180ad47b72a19aeead730 (patch)
tree77eb043f889bdda92eb65cddf1df7f06f67a7bd4
downloadaur-78b05fe670f5ea8c153180ad47b72a19aeead730.tar.gz
Initial import 0.2.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD51
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62339443bd14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-siosocks
+ pkgdesc = sans-io socks proxy client/server with couple io backends
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/pohmelie/siosocks
+ arch = any
+ license = MIT
+ checkdepends = python-pytest-asyncio
+ checkdepends = python-pytest-trio
+ checkdepends = python-trio
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/s/siosocks/siosocks-0.2.0.tar.gz
+ md5sums = 8f5eee2cdc80261a7a9560b9dcb0345f
+
+pkgname = python-siosocks
+ depends = python>=3.6
+ optdepends = python-trio: trio
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e896dcd6056d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c22775ddbba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgbase=python-siosocks
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+#"python-${_pyname}-doc")
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="sans-io socks proxy client/server with couple io backends"
+arch=('any')
+url="https://github.com/pohmelie/siosocks"
+license=('MIT')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-trio')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('8f5eee2cdc80261a7a9560b9dcb0345f')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ python setup.py build
+
+# msg "Building Docs"
+# python setup.py build_sphinx
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ #PYTHONPATH="build/lib" pytest --ignore=tests/test_socketserver.py #|| warning "Tests failed"
+ PYTHONPATH="build/lib" pytest \
+ --deselect=tests/test_socketserver.py::test_connection_socks_success || warning "Tests failed"
+}
+
+package_python-siosocks() {
+ depends=('python>=3.6')
+ optdepends=('python-trio: trio')
+# 'python-siosocks-doc: Documentation for siosocks')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 license.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 readme.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+#package_python-siosocks-doc() {
+# pkgdesc="Documentation for Python siosocks"
+# cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+#
+# install -D -m644 ../../license.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}