summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-01-06 10:57:01 -0500
committergraysky2019-01-06 10:57:01 -0500
commitebd5de3ced1ee4dff099fed78b7baf582dc48de9 (patch)
treef80d9b60932afa3f0050dcd08c77f562afbcd0d3
downloadaur-ebd5de3ced1ee4dff099fed78b7baf582dc48de9.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15642208a10b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-sip-pyqt4
+ pkgver = 4.19.13
+ pkgrel = 1
+ url = http://www.riverbankcomputing.com/software/sip/intro
+ arch = x86_64
+ license = custom:"sip"
+ makedepends = python
+ source = http://sourceforge.net/projects/pyqt/files/sip/sip-4.19.13/sip-4.19.13.tar.gz
+ sha256sums = e353a7056599bf5fbd5d3ff9842a6ab2ea3cf4e0304a0f925ec5862907c0d15e
+
+pkgname = python-sip-pyqt4
+ pkgdesc = Python 3.x SIP bindings for C and C++ libraries (PyQt4 version)
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b57e390c668b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor inemum (https://gitlab.com/inemum)
+# Maintainer graysky <graysky AT archlinux DOT us>
+# based on https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/sip
+
+pkgname=('python-sip-pyqt4')
+pkgver=4.19.13
+pkgrel=1
+arch=('x86_64')
+url='http://www.riverbankcomputing.com/software/sip/intro'
+license=('custom:"sip"')
+makedepends=('python')
+source=("http://sourceforge.net/projects/pyqt/files/sip/sip-$pkgver/sip-$pkgver.tar.gz")
+sha256sums=('e353a7056599bf5fbd5d3ff9842a6ab2ea3cf4e0304a0f925ec5862907c0d15e')
+
+prepare() {
+ mkdir -p build-pyqt4
+}
+
+build() {
+ cd "$srcdir"/build-pyqt4
+ python ../sip-$pkgver/configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS" --sip-module PyQt4.sip --no-tools
+ make
+}
+
+package_python-sip-pyqt4() {
+ pkgdesc="Python 3.x SIP bindings for C and C++ libraries (PyQt4 version)"
+ depends=('python')
+
+ cd build-pyqt4
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 ../sip-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}