summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-19 22:01:41 +0300
committerCaleb Maclennan2021-07-19 22:15:20 +0300
commit9e90919ea9d5f55aed07ba2951cd0ecab7b040e3 (patch)
treed592bf1b09d2a8d46df88225529c5fd2c8847791
parent2faf3dc3044da65f11b65f07d579a2f4395c5c6b (diff)
downloadaur-9e90919ea9d5f55aed07ba2951cd0ecab7b040e3.tar.gz
Be honest about using upstream binary, fix chroot build
This package has never properly built from source, it always used the binary wheel for Skia. Previous to this commit the machinery for that was just hidden one layer down. The pathops repo was being "built", but the build process was just using pip behind the scenes to fetch the wheel. *Actually* building this from source requires Python2 and ninja and all sorts of song and dance that I wasn't able to untangle in the time required. If/when anybody works on this they can start with the previous commit as a model, but it needs lots of work. At least this version is honest and does what it says on the tin.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0698a643a0f8..fc13bf66b47c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = python-skia-pathops
- pkgdesc = Python bindings for the Skia library’s Path Ops
+ pkgdesc = Python bindings for the Skia library’s Path Ops (wheel)
pkgver = 0.6.0.post2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fonttools/skia-pathops
arch = x86_64
license = BSD
- checkdepends = python-pytest
- checkdepends = python-pytest-cython
- makedepends = cython
- makedepends = python-setuptools
+ makedepends = python-pip
depends = python
- source = https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-0.6.0.post2.zip
- sha256sums = 5a103b5e28f1faa2d6a0d41990d822c621b7c5f34442f7abe96fc58817929ca2
+ options = !strip
+ source = https://files.pythonhosted.org/packages/cp39/s/skia-pathops/skia_pathops-0.6.0.post2-cp39-cp39-manylinux2014_x86_64.whl
+ sha256sums = dafcc11aa26e0060df01a6672bd3d32f1d00829c0bf255c6a3d9f440b339a543
pkgname = python-skia-pathops
-
diff --git a/PKGBUILD b/PKGBUILD
index 94d1b133214e..aebbfae6f8eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,27 @@
pkgname=python-skia-pathops
_pkgname=${pkgname#python-}
pkgver=0.6.0.post2
-pkgrel=1
-pkgdesc='Python bindings for the Skia library’s Path Ops'
+pkgrel=2
+pkgdesc='Python bindings for the Skia library’s Path Ops (wheel)'
arch=('x86_64')
url="https://github.com/fonttools/$_pkgname"
license=('BSD')
depends=('python')
-makedepends=('cython' 'python-setuptools')
-checkdepends=('python-pytest' 'python-pytest-cython')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.zip")
-sha256sums=('5a103b5e28f1faa2d6a0d41990d822c621b7c5f34442f7abe96fc58817929ca2')
+makedepends=('python-pip')
+options=(!strip)
+_py=cp39
+_wheel="${_pkgname/-/_}-$pkgver-$_py-$_py-manylinux2014_x86_64.whl"
+source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/$_wheel")
+sha256sums=('dafcc11aa26e0060df01a6672bd3d32f1d00829c0bf255c6a3d9f440b339a543')
-build() {
- cd "$_pkgname-$pkgver"
- python setup.py build
- python setup.py build_ext --inplace
-}
-
-check() {
- cd "$_pkgname-$pkgver"
- PYTHONPATH="src/python" pytest
-}
+# If anybody wants to muck around with the Chromium tree and figure out how to
+# build skia from source on Arch I'm open to patches, but even after mucking
+# around with ninja and Python2 and various patched bulid toolchains I have
+# come up short of a way to build this against Arch packages. Drop a comment on
+# the AUR page if you have ideas.
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ export PIP_CONFIG_FILE=/dev/null
+ pip install --isolated --root="$pkgdir" --ignore-installed --no-deps $_wheel
+ python -O -m compileall "$pkgdir"
}