summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-05-02 10:23:12 +0200
committerMartino Pilia2018-05-02 10:23:12 +0200
commit0689ab6375d3b72ce118362148a1488b30fe53c2 (patch)
tree50d074c0f3e90a22f59f0f563283ece8b2628685
downloadaur-0689ab6375d3b72ce118362148a1488b30fe53c2.tar.gz
package submission
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD19
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5a4beabf2fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-skorch
+ pkgdesc = A scikit-learn compatible neural network library that wraps pytorch
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/dnouri/skorch
+ arch = any
+ license = BSD3
+ makedepends = python-setuptools
+ depends = python-scikit-learn
+ depends = python-yaml
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-tqdm
+ depends = python-pytorch
+ depends = python-tabulate
+ source = https://github.com/dnouri/skorch/archive/v0.1.0.tar.gz
+ sha512sums = af554b72b35ab0fa3b84c107afc40153dcbc77b23c53ab03e6007f22331907f641527a45428989349dfb491780b26961f10144308710cb349f024a1e59dcc4b6
+
+pkgname = python-skorch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33131d4e82f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=skorch
+pkgname=python-$_pkgname
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A scikit-learn compatible neural network library that wraps pytorch"
+arch=('any')
+url="https://github.com/dnouri/skorch"
+license=('BSD3')
+depends=('python-scikit-learn' 'python-yaml' 'python-numpy' 'python-scipy' 'python-tqdm' 'python-pytorch' 'python-tabulate')
+makedepends=('python-setuptools')
+source=("https://github.com/dnouri/skorch/archive/v${pkgver}.tar.gz")
+sha512sums=('af554b72b35ab0fa3b84c107afc40153dcbc77b23c53ab03e6007f22331907f641527a45428989349dfb491780b26961f10144308710cb349f024a1e59dcc4b6')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root="$pkgdir"
+}