summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-02-02 13:48:26 -0800
committerclintval2018-02-02 13:48:26 -0800
commit3345d8b46b87f3bedc22a0f09be10fd0e4de26de (patch)
tree41a9b7e4bcec56751a2a95886d868e5e621433fb
parentb343ecee5488513b4f95d7388082a2547751e3af (diff)
downloadaur-3345d8b46b87f3bedc22a0f09be10fd0e4de26de.tar.gz
python-slackclient to 1.1.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 254383b21b25..b2a86d85d15d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = python-slackclient
pkgdesc = Python Slack client for the Web and RTM API
- pkgver = 1.1.0
+ pkgver = 1.1.2
pkgrel = 1
url = https://pypi.python.org/pypi/slackclient
arch = x86_64
license = MIT
+ makedepends = python
makedepends = python-setuptools
depends = python
- depends = python-websocket-client>=0.35
- depends = python-websocket-client<1.0a0
- depends = python-requests>=2.11
- depends = python-requests<3.0a0
- depends = python-six>=1.10
- depends = python-six<2.0a0
- provides = python-slackclient
- conflicts = python-slackclient
+ depends = python-websocket-client
+ depends = python-requests
+ depends = python-six
options = !emptydirs
- source = https://pypi.python.org/packages/65/86/abb78f9c1c9eb8cde227e6cfee46921ec5e536a91a0ff2934922fddc56ec/slackclient-1.1.0.tar.gz
- md5sums = a0138aa105392556dc497d5a335f0e7c
+ source = https://pypi.python.org/packages/08/6e/c84dcf7c18c0a79c17a3dec971bcfa746ea1e23d4f41ba1de7eead203266/slackclient-1.1.2.tar.gz
+ sha256sums = 2e5840eba5af71487803b4eb8427ba19e1347fae6ed25cff53e0a6ea6c6832f5
pkgname = python-slackclient
diff --git a/PKGBUILD b/PKGBUILD
index 9eb7529ba5da..5f22f921315d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
pkgname='python-slackclient'
-pkgver=1.1.0
+pkgver=1.1.2
pkgrel=1
pkgdesc="Python Slack client for the Web and RTM API"
arch=('x86_64')
url="https://pypi.python.org/pypi/slackclient"
license=('MIT')
-depends=('python'
- 'python-websocket-client>=0.35'
- 'python-websocket-client<1.0a0'
- 'python-requests>=2.11'
- 'python-requests<3.0a0'
- 'python-six>=1.10'
- 'python-six<2.0a0')
-conflicts=('python-slackclient')
-provides=('python-slackclient')
-makedepends=('python-setuptools')
+depends=(
+ 'python'
+ 'python-websocket-client'
+ 'python-requests'
+ 'python-six'
+)
+makedepends=('python' 'python-setuptools')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/65/86/abb78f9c1c9eb8cde227e6cfee46921ec5e536a91a0ff2934922fddc56ec/slackclient-1.1.0.tar.gz")
-md5sums=('a0138aa105392556dc497d5a335f0e7c')
+source=("https://pypi.python.org/packages/08/6e/c84dcf7c18c0a79c17a3dec971bcfa746ea1e23d4f41ba1de7eead203266/slackclient-1.1.2.tar.gz")
+sha256sums=('2e5840eba5af71487803b4eb8427ba19e1347fae6ed25cff53e0a6ea6c6832f5')
package() {
cd "${srcdir}/slackclient-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
-} \ No newline at end of file
+}