summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2015-09-07 18:12:30 -0700
committerTyler Veness2015-09-07 18:12:30 -0700
commit49ab5ae66df6c3ec1a980d2f30883162068460c8 (patch)
treec2ea96d087169bbedfb9b48f711949c9174aba46
downloadaur-49ab5ae66df6c3ec1a980d2f30883162068460c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c1503d84d0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-slycot-git
+ pkgdesc = Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations.
+ pkgver = tb04ad_segfault.r72.g7b674d1
+ pkgrel = 1
+ url = http://github.com/johannes-scharlach/Slycot
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = gcc-fortran
+ depends = python-numpy
+ provides = python-slycot
+ conflicts = python-slycot
+ source = git+https://github.com/johannes-scharlach/Slycot.git
+ md5sums = SKIP
+
+pkgname = python-slycot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ff8d82aef06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tyler Veness <calcmogul at gmail dot com>
+# Contributor: James Duley <jagduley gmail>
+
+pkgname=python-slycot-git
+_gitname=Slycot
+pkgver=tb04ad_segfault.r72.g7b674d1
+pkgrel=1
+pkgdesc="Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations."
+arch=('i686' 'x86_64')
+url="http://github.com/johannes-scharlach/Slycot"
+license=('GPL2')
+depends=('python-numpy')
+makedepends=('git' 'gcc-fortran')
+optdepends=()
+provides=('python-slycot')
+conflicts=('python-slycot')
+source=(git+https://github.com/johannes-scharlach/Slycot.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ export LDFLAGS="$LDFLAGS -shared"
+
+ cd "$srcdir/$_gitname"
+ python setup.py config_fc --fcompiler=gnu95 install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: