summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2015-10-31 03:17:13 -0700
committerTyler Veness2015-10-31 03:18:46 -0700
commit65b4209f028eb41f5fc6dfc858e259fdb4af0e02 (patch)
tree3d2de497373007f78ba07578d8afa552595ca003
parent49ab5ae66df6c3ec1a980d2f30883162068460c8 (diff)
downloadaur-65b4209f028eb41f5fc6dfc858e259fdb4af0e02.tar.gz
Changed Git source URL to newer repository and modified pkgver() function
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c1503d84d0c..9238fc38218e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-slycot-git
pkgdesc = Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations.
- pkgver = tb04ad_segfault.r72.g7b674d1
+ pkgver = 137.9bec0d2
pkgrel = 1
- url = http://github.com/johannes-scharlach/Slycot
+ url = http://github.com/jgoppert/Slycot
arch = i686
arch = x86_64
license = GPL2
@@ -11,7 +11,7 @@ pkgbase = python-slycot-git
depends = python-numpy
provides = python-slycot
conflicts = python-slycot
- source = git+https://github.com/johannes-scharlach/Slycot.git
+ source = git+https://github.com/jgoppert/Slycot.git
md5sums = SKIP
pkgname = python-slycot-git
diff --git a/PKGBUILD b/PKGBUILD
index 7ff8d82aef06..6d35a4c30d9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,23 @@
pkgname=python-slycot-git
_gitname=Slycot
-pkgver=tb04ad_segfault.r72.g7b674d1
+pkgver=137.9bec0d2
pkgrel=1
pkgdesc="Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations."
arch=('i686' 'x86_64')
-url="http://github.com/johannes-scharlach/Slycot"
+url="http://github.com/jgoppert/Slycot"
license=('GPL2')
depends=('python-numpy')
makedepends=('git' 'gcc-fortran')
optdepends=()
provides=('python-slycot')
conflicts=('python-slycot')
-source=(git+https://github.com/johannes-scharlach/Slycot.git)
+source=(git+https://github.com/jgoppert/Slycot.git)
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_gitname"
- # Use the tag of the last commit
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ echo $(git rev-list --count master).$(git rev-parse --short master)
}
package() {