summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2018-05-03 02:37:32 -0700
committerTyler Veness2018-05-03 02:37:32 -0700
commit7bb3ffb0fc162623a91e3e33f73288c2d639b211 (patch)
tree4b9288f01b8c4a02b1afdbed0205742bd19781bd
parent79f1374b974429690619e9b3a06440a5f4251c51 (diff)
downloadaur-7bb3ffb0fc162623a91e3e33f73288c2d639b211.tar.gz
Changed upstream URL to github.com/python-control/Slycot
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f0a97a8d49f..16021486acd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-slycot-git
pkgdesc = Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations.
- pkgver = 140.234447c
- pkgrel = 2
- url = http://github.com/jgoppert/Slycot
+ pkgver = 186.a41ac6e
+ pkgrel = 1
+ url = http://github.com/python-control/Slycot
arch = i686
arch = x86_64
license = GPL2
@@ -11,7 +11,7 @@ pkgbase = python-slycot-git
depends = python-numpy-openblas
provides = python-slycot
conflicts = python-slycot
- source = git+https://github.com/jgoppert/Slycot.git
+ source = git+https://github.com/python-control/Slycot.git
md5sums = SKIP
pkgname = python-slycot-git
diff --git a/PKGBUILD b/PKGBUILD
index 72e4ebb61047..b9262c223be6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,29 @@
# Contributor: James Duley <jagduley gmail>
pkgname=python-slycot-git
-_gitname=Slycot
-pkgver=140.234447c
-pkgrel=2
+pkgver=186.a41ac6e
+pkgrel=1
pkgdesc="Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations."
arch=('i686' 'x86_64')
-url="http://github.com/jgoppert/Slycot"
+url="http://github.com/python-control/Slycot"
license=('GPL2')
depends=('python-numpy-openblas')
makedepends=('git' 'gcc-fortran')
optdepends=()
provides=('python-slycot')
conflicts=('python-slycot')
-source=(git+https://github.com/jgoppert/Slycot.git)
+source=(git+https://github.com/python-control/Slycot.git)
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/Slycot"
echo $(git rev-list --count master).$(git rev-parse --short master)
}
package() {
export LDFLAGS="$LDFLAGS -shared"
- cd "$srcdir/$_gitname"
+ cd "$srcdir/Slycot"
python setup.py config_fc --fcompiler=gnu95 install --root="$pkgdir/" --optimize=1
}