summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-02-19 15:38:35 +0100
committerPhilipp A2022-02-19 15:38:35 +0100
commit9d42298e488c586a389d7bdcf37bc315e958d49a (patch)
tree3a6480beebde05efbce8e2f53621eae516f01672
parentb6b646ea6bbb8e842efff88e5615a8de4ce09d36 (diff)
downloadaur-9d42298e488c586a389d7bdcf37bc315e958d49a.tar.gz
build from source
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6dc8817ef21..447ccf055691 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-smart-progress
pkgdesc = Smart progressbar with multiple backends selected depending on the environment
pkgver = 1.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/flying-sheep/smart-progress
arch = any
license = GPL3
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = jupyter
depends = python-click
- source = https://files.pythonhosted.org/packages/py3/s/smart-progress/smart_progress-1.0.2-py3-none-any.whl
- md5sums = e299adff567ae9fd159745efa3bc820b
+ source = https://files.pythonhosted.org/packages/source/s/smart-progress/smart-progress-1.0.2.tar.gz
+ sha256sums = 3a2ef36aa7d3846476d44fe436ad6be68bd384e3cea4655a6185bcc82a31d280
pkgname = python-smart-progress
-
diff --git a/.gitignore b/.gitignore
index 4d7ad300862e..1d2dabc4faac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.whl
-/*.pkg.tar.xz
+/*.tar.gz
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 43831619efc8..eb9516326997 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
_name=smart-progress
pkgname=python-$_name
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc='Smart progressbar with multiple backends selected depending on the environment'
arch=('any')
url="https://github.com/flying-sheep/$_name"
-license=('GPL3')
-depends=('python' 'jupyter' 'python-click')
-makedepends=('python-pip')
-source=("https://files.pythonhosted.org/packages/py3/s/$_name/${_name/-/_}-$pkgver-py3-none-any.whl")
-md5sums=('e299adff567ae9fd159745efa3bc820b')
+license=(GPL3)
+depends=(python jupyter python-click)
+makedepends=(python-build python-installer)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('3a2ef36aa7d3846476d44fe436ad6be68bd384e3cea4655a6185bcc82a31d280')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- pip install --root="$pkgdir" --ignore-installed --no-deps "$srcdir/${_name/-/_}-$pkgver-py3-none-any.whl"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}