summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2015-08-27 09:34:52 +0200
committerPhilipp A2015-08-27 09:34:52 +0200
commitee7ecc87a9a1c93254eb90b01b1b4186bedde6c8 (patch)
tree7d8ee22790e11b2fef0ecb0236692859d51f3fb9
parent7286e704f5b392cb1c53e01b93674c3a62c8a8b0 (diff)
downloadaur-ee7ecc87a9a1c93254eb90b01b1b4186bedde6c8.tar.gz
bumped version to 1.01, fixed dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08163a47f4a6..2ac248600790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-smart-progress
pkgdesc = Smart progressbar with multiple backends selected depending on the environment
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/flying-sheep/smart-progress
arch = any
- license = Apache
- makedepends = python-setuptools
+ license = GPLv3
+ makedepends = python-pip
depends = python
- source = https://pypi.python.org/packages/source/s/smart-progress/smart-progress-1.0.0.tar.gz
- md5sums = f209cf90c991831c425e481d013f37fd
+ depends = jupyter
+ depends = python-click
+ source = https://pypi.python.org/packages/py3/s/smart-progress/smart_progress-1.0.1-py3-none-any.whl
+ md5sums = 8b7db8b4de3875f5b6db258b79a5e8ca
pkgname = python-smart-progress
diff --git a/PKGBUILD b/PKGBUILD
index a70ecd972c48..200c21300245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
_name=smart-progress
pkgname=python-$_name
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc='Smart progressbar with multiple backends selected depending on the environment'
arch=('any')
url="https://github.com/flying-sheep/$_name"
-license=('Apache')
-depends=('python')
-makedepends=('python-setuptools')
-source=("https://pypi.python.org/packages/source/s/$_name/$_name-$pkgver.tar.gz")
-md5sums=('f209cf90c991831c425e481d013f37fd')
+license=('GPLv3')
+depends=('python' 'jupyter' 'python-click')
+makedepends=('python-pip')
+source=("https://pypi.python.org/packages/py3/s/$_name/${_name/-/_}-$pkgver-py3-none-any.whl")
+md5sums=('8b7db8b4de3875f5b6db258b79a5e8ca')
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
+ pip install --root="$pkgdir" --ignore-installed --no-deps "$srcdir/${_name/-/_}-$pkgver-py3-none-any.whl"
} \ No newline at end of file