summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-13 16:11:58 -0400
committerGuillaume Horel2017-03-13 16:11:58 -0400
commit28cf852320d625bec89af71e8122b0946a275640 (patch)
treebaa630cdfff8e03889f3ae5e0dc61e375d6652a2
downloadaur-28cf852320d625bec89af71e8122b0946a275640.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD31
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..437a9847f4cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-snappy
+ pkgdesc = Python bindings for the snappy compression library.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/andrix/python-snappy
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = snappy
+ depends = python
+ source = https://pypi.python.org/packages/70/fa/621594e313b2b9074585af63668f7a31839c4e4d69df536ab592e6e1e353/python-snappy-0.5.tar.gz
+ source = LICENSE
+ sha256sums = c7fe37679ebfc73840c7cc83657a76bc1ac978efa286b8ac3569fd0630d2b80d
+ sha256sums = d007cb05f143d99d16d5cd0d1bf291daf037adb36800344e440ec26edb938f9a
+
+pkgname = python-snappy
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f5639eac24f1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2011-2017, Andres Moreira <andres@andresmoreira.com>
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the authors nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL ANDRES MOREIRA BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..271dbefa7a95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-snappy')
+pkgver='0.5'
+pkgrel=1
+pkgdesc="Python bindings for the snappy compression library."
+url="https://github.com/andrix/python-snappy"
+depends=('python')
+makedepends=('snappy')
+license=('BSD')
+arch=('i686' 'x86_64')
+source=("https://pypi.python.org/packages/70/fa/621594e313b2b9074585af63668f7a31839c4e4d69df536ab592e6e1e353/python-snappy-0.5.tar.gz"
+ "LICENSE")
+sha256sums=('c7fe37679ebfc73840c7cc83657a76bc1ac978efa286b8ac3569fd0630d2b80d'
+ 'd007cb05f143d99d16d5cd0d1bf291daf037adb36800344e440ec26edb938f9a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build_ext --inplace
+ python test_snappy.py
+}
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}