summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-05-13 18:01:46 -0400
committerGuillaume Horel2017-05-13 18:01:46 -0400
commit50b9cec14792ec13972db102d1d4300208c629d4 (patch)
treec5c14b62a3fac7b51696c9d318969bceddca2a24
parentc2b77af1c176bc422cc7af92d13da53840d636a3 (diff)
downloadaur-50b9cec14792ec13972db102d1d4300208c629d4.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a153a473841..efda1537ee0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = python-snappy
pkgdesc = Python bindings for the snappy compression library.
- pkgver = 0.5
- pkgrel = 3
+ pkgver = 0.5.1
+ pkgrel = 1
url = https://github.com/andrix/python-snappy
arch = i686
arch = x86_64
license = BSD
depends = python
depends = snappy
- source = https://pypi.python.org/packages/70/fa/621594e313b2b9074585af63668f7a31839c4e4d69df536ab592e6e1e353/python-snappy-0.5.tar.gz
- source = https://patch-diff.githubusercontent.com/raw/andrix/python-snappy/pull/38.patch
+ source = https://github.com/andrix/python-snappy/archive/0.5.1.tar.gz
source = LICENSE
- sha256sums = c7fe37679ebfc73840c7cc83657a76bc1ac978efa286b8ac3569fd0630d2b80d
- sha256sums = a8c7c75296b290a6a9846fe072cfeac33bc71fd45e8a5d3fb51d79033d80acac
+ sha256sums = cf530b5a3e05e220003cdaf09150b56620c12a6e28557def9bbf01989e193931
sha256sums = d007cb05f143d99d16d5cd0d1bf291daf037adb36800344e440ec26edb938f9a
pkgname = python-snappy
diff --git a/PKGBUILD b/PKGBUILD
index cce7f5883f45..95d0aeadf557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-snappy')
-pkgver='0.5'
-pkgrel=3
+pkgver='0.5.1'
+pkgrel=1
pkgdesc="Python bindings for the snappy compression library."
url="https://github.com/andrix/python-snappy"
depends=('python' 'snappy')
license=('BSD')
arch=('i686' 'x86_64')
-source=("https://pypi.python.org/packages/70/fa/621594e313b2b9074585af63668f7a31839c4e4d69df536ab592e6e1e353/python-snappy-0.5.tar.gz"
- "https://patch-diff.githubusercontent.com/raw/andrix/python-snappy/pull/38.patch"
+source=("https://github.com/andrix/python-snappy/archive/$pkgver.tar.gz"
"LICENSE")
-sha256sums=('c7fe37679ebfc73840c7cc83657a76bc1ac978efa286b8ac3569fd0630d2b80d'
- 'a8c7c75296b290a6a9846fe072cfeac33bc71fd45e8a5d3fb51d79033d80acac'
+sha256sums=('cf530b5a3e05e220003cdaf09150b56620c12a6e28557def9bbf01989e193931'
'd007cb05f143d99d16d5cd0d1bf291daf037adb36800344e440ec26edb938f9a')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../../38.patch
-}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build