summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2024-02-21 12:13:36 +0800
committerUniversebenzene2024-02-21 12:13:36 +0800
commite7ed1f8625a8ba78f8acadd82c37b34862a65a5a (patch)
tree3b44899542a8fd5a256ec16e2146bc0e8452b492
parent9c5276f1ee718b5248b67d228be2136db2a6bd41 (diff)
downloadaur-python-sncosmo.tar.gz
Update to version 2.10.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2b49988709c..02ee14ef48c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python-sncosmo
pkgdesc = Python library for supernova cosmology
- pkgver = 2.10.2
+ pkgver = 2.10.4
pkgrel = 1
url = https://sncosmo.readthedocs.io
arch = i686
arch = x86_64
- license = BSD
+ license = BSD-3-Clause
checkdepends = python-pytest
checkdepends = python-astropy
checkdepends = python-scipy
@@ -20,14 +20,15 @@ pkgbase = python-sncosmo
makedepends = python-build
makedepends = python-installer
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/s/sncosmo/sncosmo-2.10.2.tar.gz
- md5sums = 4fcd899e91838cd37ed785f837005463
+ source = https://files.pythonhosted.org/packages/source/s/sncosmo/sncosmo-2.10.4.tar.gz
+ md5sums = 03819f3f8f7691df666713d09292857a
pkgname = python-sncosmo
depends = python-scipy>=1.3.0
depends = python-astropy>=3.1
depends = python-extinction>=0.4.4
depends = python-yaml>=3.13
+ depends = python-looseversion>=1.0.0
optdepends = python-matplotlib: For plotting functions
optdepends = python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc
optdepends = python-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc
diff --git a/PKGBUILD b/PKGBUILD
index 25d3396d396c..143a4fd2d2c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgbase=python-sncosmo
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=2.10.2
+pkgver=2.10.4
pkgrel=1
pkgdesc="Python library for supernova cosmology"
arch=('i686' 'x86_64')
url="https://sncosmo.readthedocs.io"
-license=('BSD')
+license=('BSD-3-Clause')
makedepends=('cython'
'python-setuptools'
'python-wheel'
@@ -24,7 +24,7 @@ checkdepends=('python-pytest'
'python-matplotlib')
# 'python-yaml'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('4fcd899e91838cd37ed785f837005463')
+md5sums=('03819f3f8f7691df666713d09292857a')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -45,11 +45,11 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" -m "not might_download" || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
+ pytest -m "not might_download" "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package() {
- depends=('python-scipy>=1.3.0' 'python-astropy>=3.1' 'python-extinction>=0.4.4' 'python-yaml>=3.13')
+ depends=('python-scipy>=1.3.0' 'python-astropy>=3.1' 'python-extinction>=0.4.4' 'python-yaml>=3.13' 'python-looseversion>=1.0.0')
optdepends=('python-matplotlib: For plotting functions'
'python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc'
'python-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc'