summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-09-10 15:12:08 +0800
committerUniversebenzene2021-09-10 15:12:08 +0800
commit1462b609559abfff059645c482f79c259b11a58b (patch)
treed6cdfcd9ce6f490ed995c6a1d7d3b6c76d27cf3c
parent4ef1c28a1ea614b9dd0fbf177f6d9f6d3d927898 (diff)
downloadaur-1462b609559abfff059645c482f79c259b11a58b.tar.gz
Update to version 2.6.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a267b95a456..f515859efd14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sncosmo
pkgdesc = Python library for supernova cosmology
- pkgver = 2.5.0
+ pkgver = 2.6.0
pkgrel = 1
url = https://sncosmo.readthedocs.io
arch = i686
@@ -11,20 +11,22 @@ pkgbase = python-sncosmo
checkdepends = python-astropy
checkdepends = python-extinction
checkdepends = python-iminuit
+ checkdepends = python-emcee
+ checkdepends = python-nestle
+ checkdepends = python-matplotlib
makedepends = cython
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/s/sncosmo/sncosmo-2.5.0.tar.gz
- md5sums = 2a1f7c67b4c10734c8c1a7f8e01c74a3
+ source = https://files.pythonhosted.org/packages/source/s/sncosmo/sncosmo-2.6.0.tar.gz
+ md5sums = 8ca17749ef0257330b9e93d268b9a25d
pkgname = python-sncosmo
depends = python>=3.5
- depends = python-scipy>=0.9.0
- depends = python-astropy>=1.0.0
- depends = python-extinction>=0.2.2
+ depends = python-scipy>=0.19.0
+ depends = python-astropy>=1.3.0
+ depends = python-extinction>=0.4.2
optdepends = python-matplotlib: For plotting functions
optdepends = python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc
optdepends = python-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc
optdepends = python-nestle: For nested sampling light curve parameter estimation in sncosmo.nest_lc
optdepends = python-corner: For plotting results from the samplers sncosmo.mcmc_lc and sncosmo.nest_lc
optdepends = python-sncosmo-doc: Documentation for SNCosmo
-
diff --git a/PKGBUILD b/PKGBUILD
index 14555ba4324c..51a58623dcbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgbase=python-sncosmo
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=2.5.0
+pkgver=2.6.0
pkgrel=1
pkgdesc="Python library for supernova cosmology"
arch=('i686' 'x86_64')
url="https://sncosmo.readthedocs.io"
license=('BSD')
makedepends=('cython' 'python-numpy')
-checkdepends=('python-pytest-astropy' 'python-scipy' 'python-astropy' 'python-extinction' 'python-iminuit')
+checkdepends=('python-pytest-astropy' 'python-scipy' 'python-astropy' 'python-extinction' 'python-iminuit' 'python-emcee' 'python-nestle' 'python-matplotlib')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('2a1f7c67b4c10734c8c1a7f8e01c74a3')
+md5sums=('8ca17749ef0257330b9e93d268b9a25d')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
@@ -26,12 +26,11 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- cp "build/lib.linux-${CARCH}-${_pyver}/${_pyname}/salt2utils.cpython-${_pyver/./}-${CARCH}-linux-gnu.so" "${_pyname}"
- pytest || warning "Tests failed"
+ pytest "build/lib.linux-${CARCH}-${_pyver}" || warning "Tests failed"
}
package() {
- depends=('python>=3.5' 'python-scipy>=0.9.0' 'python-astropy>=1.0.0' 'python-extinction>=0.2.2')
+ depends=('python>=3.5' 'python-scipy>=0.19.0' 'python-astropy>=1.3.0' 'python-extinction>=0.4.2')
optdepends=('python-matplotlib: For plotting functions'
'python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc'
'python-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc'