summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-05-11 13:51:17 +0200
committerEmiel Wiedijk2018-05-11 13:51:17 +0200
commitdc4638dc53468985115f022a70945e6d70eb3f6a (patch)
tree2341d0d7954d1e14e2322b375a7e2adfe7ac869b
parent6a9de643e055f90dd8d9b8cf15d66ffe0d562d03 (diff)
downloadaur-python-snowboy-git.tar.gz
Fix conflicts/provides array
Previously the entire package conflicted with/provided with python-snowboy. Since the python 2 version and the python 3 version both conflicted with the same package, they conflicted with each other as well. Now they conflict with the tagged package that provides the same python version.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cd8ee3fec50..3f610c517238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-snowboy-git
pkgdesc = A hotword detection engine - Python bindings
- pkgver = v1.3.0.r3.g75ef4f5
+ pkgver = v1.3.0.r31.g797a17e
pkgrel = 1
url = https://snowboy.kitt.ai/
arch = x86_64
@@ -10,16 +10,18 @@ pkgbase = python-snowboy-git
makedepends = python2-setuptools
makedepends = swig
makedepends = cblas
- provides = python-snowboy
- conflicts = python-snowboy
source = git+https://github.com/Kitt-AI/snowboy.git
md5sums = SKIP
pkgname = python-snowboy-git
depends = cblas
depends = python-pyaudio
+ provides = python-snowboy
+ conflicts = python-snowboy
pkgname = python2-snowboy-git
depends = cblas
depends = python2-pyaudio
+ provides = python2-snowboy
+ conflicts = python2-snowboy
diff --git a/PKGBUILD b/PKGBUILD
index b6396d5d66fd..0141d80275f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-snowboy-git' 'python2-snowboy-git')
pkgbase=python-snowboy-git
_pkgname=snowboy
-pkgver=v1.3.0.r3.g75ef4f5
+pkgver=v1.3.0.r31.g797a17e
pkgrel=1
pkgdesc="A hotword detection engine - Python bindings"
arch=('x86_64')
@@ -15,8 +15,6 @@ makedepends=(
'swig'
'cblas'
)
-conflicts=('python-snowboy')
-provides=('python-snowboy')
source=("git+https://github.com/Kitt-AI/snowboy.git")
md5sums=('SKIP')
@@ -45,6 +43,8 @@ build() {
}
package_python-snowboy-git() {
+ conflicts=('python-snowboy')
+ provides=('python-snowboy')
depends=('cblas' 'python-pyaudio')
cd "${_pkgname}"
@@ -55,6 +55,8 @@ package_python-snowboy-git() {
}
package_python2-snowboy-git() {
+ conflicts=('python2-snowboy')
+ provides=('python2-snowboy')
depends=('cblas' 'python2-pyaudio')
cd "$_pkgname-py2"