summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-02-10 18:53:49 +0100
committerEmiel Wiedijk2018-02-10 18:59:59 +0100
commit4e8078a6146ad129bf04d24c6dd3dc2d1def5b36 (patch)
treef5f488267bd054ee48b0cd536767d1f50da911b5
parent3e9044cf8afa705e9b0009a951f4ab29c5f6eeae (diff)
downloadaur-4e8078a6146ad129bf04d24c6dd3dc2d1def5b36.tar.gz
Update dependencies
* Add python-pyaudio as a dependency, since it's needed for audio input. Because it depends on python also remove python from the dependencies. * Since after patching the build system, atlas-lapack apparently is not needed, patch the build flags to remove atlas and build with only cblas and lapack. Both are in the official repositories, contrary to atlas-lapack. Thanks for xantares for noticing this.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c44de4f4bcc2..62abc21e7a3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,9 @@ pkgbase = python-snowboy-git
makedepends = git
makedepends = python-setuptools
makedepends = swig
- depends = python
- depends = atlas-lapack
+ depends = cblas
+ depends = lapack
+ depends = python-pyaudio
provides = python-snowboy
conflicts = python-snowboy
source = git+https://github.com/Kitt-AI/snowboy.git
diff --git a/PKGBUILD b/PKGBUILD
index bfd05ca15053..02493f57cec7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,9 @@ arch=('x86_64')
url="https://snowboy.kitt.ai/"
license=('Apache')
depends=(
- 'python'
- 'atlas-lapack'
+ 'cblas'
+ 'lapack'
+ 'python-pyaudio'
)
makedepends=(
'git'
@@ -31,6 +32,11 @@ build() {
python setup.py build
}
+prepare() {
+ cd "$_pkgname"
+ sed -i "s|-lf77blas -lcblas -llapack -latlas|-lcblas -llapack|g" \
+ swig/Python3/Makefile
+}
package() {
cd "$_pkgname"