summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-02-23 16:53:57 +0100
committerEmiel Wiedijk2018-02-23 16:53:57 +0100
commitc0db8ed95f1989fa6b4a4f1248a8a180b4e7adac (patch)
tree08771620725006fb8a59041ccb2886e7fa9f19d7
parentcd6cb3cc698d179407b13f88d6876c45a02fc4a4 (diff)
downloadaur-c0db8ed95f1989fa6b4a4f1248a8a180b4e7adac.tar.gz
Put prepare function before build function
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a7324abd953..d30c3a1cdccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,17 +27,17 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "$_pkgname"
- python setup.py build
-}
-
prepare() {
cd "$_pkgname"
sed -i "s|-lf77blas -lcblas -llapack -latlas|-lcblas -llapack|g" \
swig/Python3/Makefile
}
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
package() {
cd "$_pkgname"
python setup.py install --root="$pkgdir/" --prefix=/usr