summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-05-23 22:07:08 +0200
committerSimon Legner2018-05-23 22:07:08 +0200
commite9422bb790e0ae17cca00020295ef2ff07d65f22 (patch)
tree0a55a4a7504711a809dadd9ddf73757d28b4e32c
downloadaur-e9422bb790e0ae17cca00020295ef2ff07d65f22.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75fd745d0a5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-snuggs
+ pkgdesc = Snuggs are s-expressions for Numpy
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://github.com/mapbox/snuggs
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/snuggs/snuggs-1.4.1.tar.gz
+ sha256sums = e1d3c9364cec1b1b938627ebfc74f040be66711072d3ae754d844b9435f4940c
+
+pkgname = python-snuggs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8c26f43ea8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=('python-snuggs')
+_module='snuggs'
+pkgver='1.4.1'
+pkgrel=1
+pkgdesc="Snuggs are s-expressions for Numpy"
+url="https://github.com/mapbox/snuggs"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/s/$_module/$_module-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir/$_module-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_module-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('e1d3c9364cec1b1b938627ebfc74f040be66711072d3ae754d844b9435f4940c')