summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2020-07-04 14:13:36 +0200
committerPeter Mattern2020-07-04 14:13:36 +0200
commitdf68c74e7c453c589449113925aa57d320d18bc6 (patch)
tree564c52a3c3991694712b9c00963d3f3771b07f0c
parentb93f5b64e75d915a3f6c815ffab9ab0318716d42 (diff)
downloadaur-df68c74e7c453c589449113925aa57d320d18bc6.tar.gz
Upstream update: release 4.0.0
This release removes support of Python 2, as it had to be removed from release 3.4.0 of the core component, too.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 14 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c063b826de6..fd8fb83bb899 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,14 @@
pkgbase = python-social-auth-app-django
- pkgdesc = Django component of the python-social-auth ecosystem
- pkgver = 2.1.0
+ pkgdesc = Python Social Auth Django component
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/python-social-auth/social-app-django
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-social-auth-core
- makedepends = python2-social-auth-core
- source = python-social-auth-app-django-2.1.0.tar.gz::https://github.com/python-social-auth/social-app-django/archive/2.1.0.tar.gz
- sha256sums = 9587984a317bbec2c8246db28404f064598ed8fea9b06af0b7337fe300569606
-
-pkgname = python-social-auth-app-django
depends = python-social-auth-core
+ source = python-social-auth-app-django-4.0.0.tar.gz::https://github.com/python-social-auth/social-app-django/archive/4.0.0.tar.gz
+ sha256sums = 5c030bf14c101b26a9039aa4395507b03f70be3a1ba1001f49c550108d0b51d1
-pkgname = python2-social-auth-app-django
- depends = python2-social-auth-core
+pkgname = python-social-auth-app-django
diff --git a/PKGBUILD b/PKGBUILD
index 1c978ae510e6..add0ac435678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,25 @@
# Maintainer: Peter Mattern <pmattern at arcor dot de>
-pkgbase=python-social-auth-app-django
-pkgname=(${pkgbase} 'python2-social-auth-app-django')
-pkgver=2.1.0
+pkgname=python-social-auth-app-django
+pkgver=4.0.0
pkgrel=1
-pkgdesc='Django component of the python-social-auth ecosystem'
+pkgdesc='Python Social Auth Django component'
arch=('any')
url='https://github.com/python-social-auth/social-app-django'
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-social-auth-core' 'python2-social-auth-core')
-source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/python-social-auth/social-app-django/archive/${pkgver}.tar.gz")
-sha256sums=('9587984a317bbec2c8246db28404f064598ed8fea9b06af0b7337fe300569606')
-
-prepare() {
- cp -r social-app-django-${pkgver} social-app-django-${pkgver}-python2
-}
+depends=('python-social-auth-core')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('5c030bf14c101b26a9039aa4395507b03f70be3a1ba1001f49c550108d0b51d1')
build() {
- cd ${srcdir}/social-app-django-${pkgver}
+ cd social-app-django-${pkgver}
python setup.py build
- cd ${srcdir}/social-app-django-${pkgver}-python2
- python2 setup.py build
-
}
-package_python-social-auth-app-django() {
-
- depends=('python-social-auth-core')
+package() {
cd social-app-django-${pkgver}
python setup.py install --root ${pkgdir} --optimize=1
@@ -36,14 +27,3 @@ package_python-social-auth-app-django() {
install -Dm644 ${srcdir}/social-app-django-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-
-package_python2-social-auth-app-django() {
-
- depends=('python2-social-auth-core')
-
- cd social-app-django-${pkgver}-python2
- python2 setup.py install --root ${pkgdir} --optimize=1
-
- install -Dm644 ${srcdir}/social-app-django-${pkgver}-python2/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-
-}