summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2017-01-30 23:46:31 +0100
committerPeter Mattern2017-01-30 23:46:31 +0100
commit3ada0bd1c3fb2941fe569f8567a14bb3f0e31b97 (patch)
tree7ab8493ce4f7f0a06c6707c55c6fe59f2fe1bbbf
downloadaur-3ada0bd1c3fb2941fe569f8567a14bb3f0e31b97.tar.gz
Initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD51
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..027b0e988ea5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by mksrcinfo v8
+# Mon Jan 30 21:39:54 UTC 2017
+pkgbase = python-social-auth-core
+ pkgdesc = Core component of the python-social-auth ecosystem
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/python-social-auth/social-core
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = python-defusedxml
+ makedepends = python-six
+ makedepends = python-pyjwt
+ makedepends = python-requests-oauthlib
+ makedepends = python-openid
+ makedepends = python2-defusedxml
+ makedepends = python2-six
+ makedepends = python2-pyjwt
+ makedepends = python2-requests-oauthlib
+ makedepends = python2-openid
+ source = python-social-auth-core-1.0.1.tar.gz::https://github.com/python-social-auth/social-core/archive/1.0.1.tar.gz
+ sha256sums = becdae55c3d050ec456844f282e6b468df0847b131e615017019ca97b631d972
+
+pkgname = python-social-auth-core
+ depends = python-defusedxml
+ depends = python-six
+ depends = python-pyjwt
+ depends = python-requests-oauthlib
+ depends = python-openid
+
+pkgname = python2-social-auth-core
+ depends = python2-defusedxml
+ depends = python2-six
+ depends = python2-pyjwt
+ depends = python2-requests-oauthlib
+ depends = python2-openid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae16fb594b83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+pkgbase=python-social-auth-core
+pkgname=($pkgbase 'python2-social-auth-core')
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Core component of the python-social-auth ecosystem'
+arch=('any')
+url='https://github.com/python-social-auth/social-core'
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools'
+ 'python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid'
+ 'python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/python-social-auth/social-core/archive/$pkgver.tar.gz")
+sha256sums=('becdae55c3d050ec456844f282e6b468df0847b131e615017019ca97b631d972')
+
+prepare() {
+ cp -r social-core-$pkgver social-core-$pkgver-python2
+}
+
+build() {
+
+ cd $srcdir/social-core-$pkgver
+ python setup.py build
+
+ cd $srcdir/social-core-$pkgver-python2
+ python2 setup.py build
+
+}
+
+package_python-social-auth-core() {
+
+ depends=('python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid')
+
+ cd social-core-$pkgver
+ python setup.py install --root $pkgdir --optimize=1
+
+ install -Dm644 $srcdir/social-core-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}
+
+package_python2-social-auth-core() {
+
+ depends=('python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
+
+ cd social-core-$pkgver-python2
+ python2 setup.py install --root $pkgdir --optimize=1
+
+ install -Dm644 $srcdir/social-core-$pkgver-python2/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}