summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302021-10-03 01:47:23 +0200
committerM0Rf302021-10-03 01:47:23 +0200
commit920858ab9bfdd11327b2714023e12462cb90de43 (patch)
tree8518fa0daf6efe0836ec998af15039e19a8dfa0e
parentbd364dde6adb624358f279246dcdce3038903cbf (diff)
downloadaur-920858ab9bfdd11327b2714023e12462cb90de43.tar.gz
python-social-auth-core: 4.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec65cb80f98f..b5685d30e8ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-social-auth-core
pkgdesc = Python Social Auth core component
- pkgver = 3.4.0
- pkgrel = 2
+ pkgver = 4.1.0
+ pkgrel = 1
url = https://github.com/python-social-auth/social-core
arch = any
license = BSD
@@ -14,8 +14,7 @@ pkgbase = python-social-auth-core
depends = python-openid
depends = python-cryptography
depends = python3-saml
- source = python-social-auth-core-3.4.0.tar.gz::https://github.com/python-social-auth/social-core/archive/3.4.0.tar.gz
- sha256sums = 06e137cf87a23bd077541523833b29f481081dd7ee143651b758db701032e606
+ source = python-social-auth-core-4.1.0.tar.gz::https://github.com/python-social-auth/social-core/archive/4.1.0.tar.gz
+ sha256sums = 3398690b33e42f6be8637742f5b737d86aa406e8c966ef717a2dafa4afdce213
pkgname = python-social-auth-core
-
diff --git a/PKGBUILD b/PKGBUILD
index 0600990d9366..3b643c2be566 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
-# Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Maintainer: robertfoster
+# Contributor: Peter Mattern <pmattern at arcor dot de>
pkgname=python-social-auth-core
-pkgver=3.4.0
-pkgrel=2
+pkgver=4.1.0
+pkgrel=1
pkgdesc='Python Social Auth core component'
arch=('any')
url='https://github.com/python-social-auth/social-core'
license=('BSD')
depends=('python-six' 'python-defusedxml' 'python-pyjwt' 'python-jose' 'python-requests-oauthlib'
- 'python-openid' 'python-cryptography' 'python3-saml')
+ 'python-openid' 'python-cryptography' 'python3-saml')
makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('06e137cf87a23bd077541523833b29f481081dd7ee143651b758db701032e606')
+sha256sums=('3398690b33e42f6be8637742f5b737d86aa406e8c966ef717a2dafa4afdce213')
build() {
-
- cd social-core-${pkgver}
- python setup.py build
-
+ cd social-core-"${pkgver}"
+ python setup.py build
}
package() {
+ cd social-core-"${pkgver}"
+ python setup.py install \
+ --root "${pkgdir}" \
+ --optimize=1
- cd social-core-${pkgver}
- python setup.py install --root ${pkgdir} --optimize=1
-
- install -Dm644 ${srcdir}/social-core-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-
+ install -Dm644 "${srcdir}/social-core-${pkgver}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}