summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2018-08-31 02:50:52 +0200
committerPeter Mattern2018-08-31 02:50:52 +0200
commitf6bb392b130d94f1cba3b1f634472a6b0bb3806c (patch)
tree57e86b5b9572c33d1cb7f88b687ff29b9d8a9ab0
parent3b53398a18034831f6cf6b7de23d2e4c6bd8ae41 (diff)
downloadaur-f6bb392b130d94f1cba3b1f634472a6b0bb3806c.tar.gz
Upstream update: release 1.7.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
2 files changed, 37 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30788bbd1d58..a6847c6801a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,44 @@
-# Generated by mksrcinfo v8
-# Sat Feb 11 09:57:15 UTC 2017
pkgbase = python-social-auth-core
pkgdesc = Core component of the python-social-auth ecosystem
- pkgver = 1.2.0
+ pkgver = 1.7.0
pkgrel = 1
url = https://github.com/python-social-auth/social-core
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
makedepends = python-defusedxml
- makedepends = python-six
makedepends = python-pyjwt
+ makedepends = python-pyjwkest
makedepends = python-requests-oauthlib
makedepends = python-openid
+ makedepends = python-cryptography
+ makedepends = python3-saml
+ makedepends = python2-setuptools
makedepends = python2-defusedxml
- makedepends = python2-six
makedepends = python2-pyjwt
+ makedepends = python2-pyjwkest
makedepends = python2-requests-oauthlib
makedepends = python2-openid
- source = python-social-auth-core-1.2.0.tar.gz::https://github.com/python-social-auth/social-core/archive/1.2.0.tar.gz
- sha256sums = e36e86cb950961d106180765c4ffcbc674d1014b8bb233fac5c0493b5cf14d9d
+ makedepends = python2-cryptography
+ makedepends = python2-saml
+ source = python-social-auth-core-1.7.0.tar.gz::https://github.com/python-social-auth/social-core/archive/1.7.0.tar.gz
+ sha256sums = c12480159bc7a8ed5d71627103e70cbe8ce63af1bf6f4f1d265d8e9b6c58c39c
pkgname = python-social-auth-core
depends = python-defusedxml
- depends = python-six
depends = python-pyjwt
+ depends = python-pyjwkest
depends = python-requests-oauthlib
depends = python-openid
+ depends = python-cryptography
+ depends = python3-saml
pkgname = python2-social-auth-core
depends = python2-defusedxml
- depends = python2-six
depends = python2-pyjwt
+ depends = python2-pyjwkest
depends = python2-requests-oauthlib
depends = python2-openid
+ depends = python2-cryptography
+ depends = python2-saml
diff --git a/PKGBUILD b/PKGBUILD
index 4459c7e45c1f..84319bd716fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,54 @@
# Maintainer: Peter Mattern <pmattern at arcor dot de>
pkgbase=python-social-auth-core
-pkgname=($pkgbase 'python2-social-auth-core')
-pkgver=1.2.0
+pkgname=(${pkgbase} 'python2-social-auth-core')
+pkgver=1.7.0
pkgrel=1
pkgdesc='Core component of the python-social-auth ecosystem'
arch=('any')
url='https://github.com/python-social-auth/social-core'
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools'
- 'python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid'
- 'python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/python-social-auth/social-core/archive/$pkgver.tar.gz")
-sha256sums=('e36e86cb950961d106180765c4ffcbc674d1014b8bb233fac5c0493b5cf14d9d')
+makedepends=('python-setuptools' 'python-defusedxml' 'python-pyjwt' 'python-pyjwkest' 'python-requests-oauthlib'
+ 'python-openid' 'python-cryptography' 'python3-saml'
+ 'python2-setuptools' 'python2-defusedxml' 'python2-pyjwt' 'python2-pyjwkest' 'python2-requests-oauthlib'
+ 'python2-openid' 'python2-cryptography' 'python2-saml')
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/python-social-auth/social-core/archive/${pkgver}.tar.gz")
+sha256sums=('c12480159bc7a8ed5d71627103e70cbe8ce63af1bf6f4f1d265d8e9b6c58c39c')
prepare() {
- cp -r social-core-$pkgver social-core-$pkgver-python2
+ cp -r social-core-${pkgver} social-core-${pkgver}-python2
}
build() {
- cd $srcdir/social-core-$pkgver
+ cd ${srcdir}/social-core-${pkgver}
python setup.py build
- cd $srcdir/social-core-$pkgver-python2
+ cd ${srcdir}/social-core-${pkgver}-python2
python2 setup.py build
}
package_python-social-auth-core() {
- depends=('python-defusedxml' 'python-six' 'python-pyjwt' 'python-requests-oauthlib' 'python-openid')
+ depends=('python-defusedxml' 'python-pyjwt' 'python-pyjwkest' 'python-requests-oauthlib'
+ 'python-openid' 'python-cryptography' 'python3-saml')
- cd social-core-$pkgver
- python setup.py install --root $pkgdir --optimize=1
+ cd social-core-${pkgver}
+ python setup.py install --root ${pkgdir} --optimize=1
- install -Dm644 $srcdir/social-core-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 ${srcdir}/social-core-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
package_python2-social-auth-core() {
- depends=('python2-defusedxml' 'python2-six' 'python2-pyjwt' 'python2-requests-oauthlib' 'python2-openid')
+ depends=('python2-defusedxml' 'python2-pyjwt' 'python2-pyjwkest' 'python2-requests-oauthlib'
+ 'python2-openid' 'python2-cryptography' 'python2-saml')
- cd social-core-$pkgver-python2
- python2 setup.py install --root $pkgdir --optimize=1
+ cd social-core-${pkgver}-python2
+ python2 setup.py install --root ${pkgdir} --optimize=1
- install -Dm644 $srcdir/social-core-$pkgver-python2/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 ${srcdir}/social-core-${pkgver}-python2/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}