summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Owens2020-05-06 21:39:23 -0500
committerNathan Owens2020-05-06 21:40:40 -0500
commit33737dff69eecfab5aff0725756c3338adfa1cc1 (patch)
tree7f0f66e55f4a237095b620fe638ebe6265b9d073
parentd5dacc1f39c052b61dac2f91935511257d8dbb59 (diff)
downloadaur-python-sockjs.tar.gz
Apply race patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1729780c3993..d92a166615a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-sockjs
pkgdesc = SockJS server implementation for aiohttp.
pkgver = 0.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aio-libs/sockjs/
arch = any
license = Apache
@@ -9,7 +9,9 @@ pkgbase = python-sockjs
makedepends = git
depends = python
source = git+https://github.com/aio-libs/sockjs#tag=v0.10.0
+ source = race.patch::https://github.com/aio-libs/sockjs/commit/63f25ed43f281d21b9b88c79926d5258655bb8f4.patch
sha256sums = SKIP
+ sha256sums = d524608e1271e7b3a37efe260fa034556a53a0bbaef0d6fbccfb174a32b77a90
pkgname = python-sockjs
diff --git a/PKGBUILD b/PKGBUILD
index 54e250d77342..19cb46bef286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,22 @@
pkgname=python-sockjs
pkgver='0.10.0'
-pkgrel=1
+pkgrel=2
pkgdesc="SockJS server implementation for aiohttp."
url="https://github.com/aio-libs/sockjs/"
depends=('python')
makedepends=('python-setuptools' 'git')
license=('Apache')
arch=('any')
-source=("git+https://github.com/aio-libs/sockjs#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://github.com/aio-libs/sockjs#tag=v${pkgver}"
+ "race.patch::https://github.com/aio-libs/sockjs/commit/63f25ed43f281d21b9b88c79926d5258655bb8f4.patch")
+sha256sums=('SKIP'
+ 'd524608e1271e7b3a37efe260fa034556a53a0bbaef0d6fbccfb174a32b77a90')
+
+prepare() {
+ cd "$srcdir/sockjs"
+ git apply --stat "$srcdir"/*.patch
+}
build() {
cd "$srcdir/sockjs"