summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyqsimon2024-03-28 14:02:39 +0800
committercyqsimon2024-03-28 14:02:39 +0800
commitf19724aeb6f5672fa14bb53ae5a89a37329e1807 (patch)
tree76e464feed68f27d7c57db41d0f260d018c799c5
parent4358a302e2952cbfb5f4534d59d0ad751ce199e7 (diff)
downloadaur-f19724aeb6f5672fa14bb53ae5a89a37329e1807.tar.gz
0.4.3
- Source switched to PyPi because there is no GitHub release - Also, seems like license is now included in PyPi package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aefe5b037170..d6e55801afeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-soundcard
pkgdesc = Play and record audio without resorting to CPython extensions
- pkgver = 0.4.2
+ pkgver = 0.4.3
pkgrel = 1
url = https://github.com/bastibe/soundcard
arch = any
@@ -12,7 +12,7 @@ pkgbase = python-soundcard
depends = pulseaudio
depends = python-cffi
depends = python-numpy
- source = python-soundcard-0.4.2.tar.gz::https://github.com/bastibe/soundcard/archive/0.4.2.tar.gz
- sha256sums = 3457c474a281d67f773e1ddd0f340032f23789e30280d2cb3f7cf2b08769c303
+ source = python-soundcard-0.4.3.tar.gz::https://files.pythonhosted.org/packages/source/S/SoundCard/SoundCard-0.4.3.tar.gz
+ sha256sums = 410835514ba10809803cb9887d4270f392b59eaf365915bb94516af3f8b1d037
pkgname = python-soundcard
diff --git a/PKGBUILD b/PKGBUILD
index ac1f94feb055..091d92259779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,9 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Jonas Heinrich <onny@project-insantiy.org>
-## license not available in pypi source package
-
pkgname=python-soundcard
_pkg=SoundCard
-pkgver=0.4.2
+pkgver=0.4.3
pkgrel=1
pkgdesc='Play and record audio without resorting to CPython extensions'
arch=('any')
@@ -14,8 +12,9 @@ url='https://github.com/bastibe/soundcard'
license=('BSD')
depends=('pulseaudio' 'python-cffi' 'python-numpy')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('3457c474a281d67f773e1ddd0f340032f23789e30280d2cb3f7cf2b08769c303')
+#source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('410835514ba10809803cb9887d4270f392b59eaf365915bb94516af3f8b1d037')
build() {
cd "$_pkg-$pkgver"