summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2022-03-30 15:06:09 +0300
committerPhilipp Joram2022-03-30 15:06:09 +0300
commit859024405e8a9dd9134ec7a79f7d88ab0688847f (patch)
tree092920456d8020af1d6083f58a69bf44e34560ac
downloadaur-859024405e8a9dd9134ec7a79f7d88ab0688847f.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f063e9b8f55a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-soundcloud-v2
+ pkgdesc = Simplify creation of data classes (PEP 557) from dictionaries.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/konradhalas/dacite
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ conflicts = python-soundcloud
+ source = https://files.pythonhosted.org/packages/source/s/soundcloud-v2/soundcloud-v2-1.3.0.tar.gz
+ sha512sums = 70fa57dd5f77438806fd5b5ce56cc7330b4a41e00f989d0c097998e90f62de3080d1e03d36d9234d2aaf5537df544e2f07ecc03b69873080f9594126e53e91a4
+
+pkgname = python-soundcloud-v2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4f799e5847f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Philipp Joram <mail [at] phijor [dot] me>
+
+pkgname='python-soundcloud-v2'
+_name=${pkgname#python-}
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Simplify creation of data classes (PEP 557) from dictionaries."
+url="https://github.com/konradhalas/dacite"
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+conflicts=('python-soundcloud')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('70fa57dd5f77438806fd5b5ce56cc7330b4a41e00f989d0c097998e90f62de3080d1e03d36d9234d2aaf5537df544e2f07ecc03b69873080f9594126e53e91a4')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: