summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-09 21:00:37 +0100
committerMichel Zou2018-01-09 21:00:37 +0100
commit4fc6178f45b6f11d25124e948f7c83622f9ac6fb (patch)
tree48cb68974ffb8870f0ac2944123d189d07388bd1
parentda6fc1dcac0bc2d9fd84c9a5a2d9465fa90237c9 (diff)
downloadaur-4fc6178f45b6f11d25124e948f7c83622f9ac6fb.tar.gz
0.10.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 644407711349..36d2ef8af5d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 21 18:00:11 UTC 2017
+# Tue Jan 9 20:00:37 UTC 2018
pkgbase = python-soundfile
pkgdesc = An audio library based on libsndfile, CFFI and NumPy
- pkgver = 0.9.0
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/bastibe/PySoundFile
arch = any
@@ -14,8 +14,8 @@ pkgbase = python-soundfile
makedepends = python2-cffi
makedepends = python-numpy
makedepends = python2-numpy
- source = https://github.com/bastibe/PySoundFile/archive/0.9.0.tar.gz
- sha1sums = 54ef9ffa57854513f7bd0de6bdaaa7e4f108e65e
+ source = https://github.com/bastibe/PySoundFile/archive/0.10.0.tar.gz
+ sha256sums = d417177bb7e701f06b625f37711be0e94c2c75e74ab3c39a368481a449a91c5c
pkgname = python-soundfile
depends = python-cffi
diff --git a/PKGBUILD b/PKGBUILD
index 2f5692d29752..2b3377e709a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgbase=python-soundfile
pkgname=('python-soundfile' 'python2-soundfile')
-pkgver=0.9.0
+pkgver=0.10.0
pkgrel=1
pkgdesc="An audio library based on libsndfile, CFFI and NumPy"
url="https://github.com/bastibe/PySoundFile"
@@ -8,29 +8,29 @@ arch=('any')
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'libsndfile' 'python-cffi' 'python2-cffi' 'python-numpy' 'python2-numpy')
source=("https://github.com/bastibe/PySoundFile/archive/${pkgver}.tar.gz")
-sha1sums=('54ef9ffa57854513f7bd0de6bdaaa7e4f108e65e')
+sha256sums=('d417177bb7e701f06b625f37711be0e94c2c75e74ab3c39a368481a449a91c5c')
build() {
- cp -r "${srcdir}"/PySoundFile-$pkgver "${srcdir}"/PySoundFile-$pkgver-py2
+ cp -r "${srcdir}"/SoundFile-$pkgver "${srcdir}"/SoundFile-$pkgver-py2
- cd "${srcdir}"/PySoundFile-$pkgver
+ cd "${srcdir}"/SoundFile-$pkgver
python setup.py build
- cd "${srcdir}"/PySoundFile-$pkgver-py2
+ cd "${srcdir}"/SoundFile-$pkgver-py2
python2 setup.py build
}
package_python-soundfile() {
depends=('python-cffi' 'libsndfile' 'python-numpy')
- cd "${srcdir}/PySoundFile-$pkgver"
+ cd "${srcdir}/SoundFile-$pkgver"
python setup.py install --root=${pkgdir} --optimize=1
}
package_python2-soundfile() {
depends=('python2-cffi' 'libsndfile' 'python2-numpy')
- cd "${srcdir}/PySoundFile-$pkgver"
+ cd "${srcdir}/SoundFile-$pkgver"
python2 setup.py install --root=${pkgdir} --optimize=1
}