summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-05-21 20:00:11 +0200
committerMichel Zou2017-05-21 20:00:11 +0200
commitda6fc1dcac0bc2d9fd84c9a5a2d9465fa90237c9 (patch)
tree1bacda15a5c51c6fa58871bc75d9d78e4331178b
downloadaur-da6fc1dcac0bc2d9fd84c9a5a2d9465fa90237c9.tar.gz
0.9.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD36
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..644407711349
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Sun May 21 18:00:11 UTC 2017
+pkgbase = python-soundfile
+ pkgdesc = An audio library based on libsndfile, CFFI and NumPy
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/bastibe/PySoundFile
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = libsndfile
+ makedepends = python-cffi
+ makedepends = python2-cffi
+ makedepends = python-numpy
+ makedepends = python2-numpy
+ source = https://github.com/bastibe/PySoundFile/archive/0.9.0.tar.gz
+ sha1sums = 54ef9ffa57854513f7bd0de6bdaaa7e4f108e65e
+
+pkgname = python-soundfile
+ depends = python-cffi
+ depends = libsndfile
+ depends = python-numpy
+
+pkgname = python2-soundfile
+ depends = python2-cffi
+ depends = libsndfile
+ depends = python2-numpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f5692d29752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgbase=python-soundfile
+pkgname=('python-soundfile' 'python2-soundfile')
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="An audio library based on libsndfile, CFFI and NumPy"
+url="https://github.com/bastibe/PySoundFile"
+arch=('any')
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools' 'libsndfile' 'python-cffi' 'python2-cffi' 'python-numpy' 'python2-numpy')
+source=("https://github.com/bastibe/PySoundFile/archive/${pkgver}.tar.gz")
+sha1sums=('54ef9ffa57854513f7bd0de6bdaaa7e4f108e65e')
+
+build() {
+ cp -r "${srcdir}"/PySoundFile-$pkgver "${srcdir}"/PySoundFile-$pkgver-py2
+
+ cd "${srcdir}"/PySoundFile-$pkgver
+ python setup.py build
+
+ cd "${srcdir}"/PySoundFile-$pkgver-py2
+ python2 setup.py build
+}
+
+package_python-soundfile() {
+ depends=('python-cffi' 'libsndfile' 'python-numpy')
+
+ cd "${srcdir}/PySoundFile-$pkgver"
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+package_python2-soundfile() {
+ depends=('python2-cffi' 'libsndfile' 'python2-numpy')
+
+ cd "${srcdir}/PySoundFile-$pkgver"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+