summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-10-01 10:54:25 +0200
committerChristopher Arndt2022-10-01 10:54:25 +0200
commite5e7d80895b2d0f73ab35e5194e04d07e1c47579 (patch)
treebaea57c3106717b20403247c5e06d079992d45ed
parent955fc25997e26da277322719ba93ddbf0b7c7ca8 (diff)
downloadaur-e5e7d80895b2d0f73ab35e5194e04d07e1c47579.tar.gz
fix make and check depends and switch back to setuptools based test command
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0113ce3ad0f..a8ca9739b47a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-soundfile
pkgdesc = A Python library to read and write audio files using libsndfile, CFFI and NumPy
pkgver = 0.11.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/bastibe/python-soundfile
arch = any
license = BSD
checkdepends = python-pytest
+ checkdepends = python-setuptools
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
depends = python-cffi
depends = libsndfile
diff --git a/PKGBUILD b/PKGBUILD
index bf1f1cd4a3a7..3bd9692cfe2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_name=soundfile
pkgname=python-soundfile
pkgver=0.11.0
-pkgrel=2
+pkgrel=3
pkgdesc='A Python library to read and write audio files using libsndfile, CFFI and NumPy'
url='https://github.com/bastibe/python-soundfile'
arch=(any)
license=(BSD)
-makedepends=(python-build python-installer python-wheel)
depends=(python-cffi libsndfile python-numpy)
-checkdepends=(python-pytest)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest python-setuptools)
source=("https://github.com/bastibe/python-soundfile/releases/download/$pkgver/$_name-$pkgver.tar.gz")
sha256sums=('931738a1c93e8684c2d3e1d514ac63440ce827ec783ea0a2d3e4730e3dc58c18')
@@ -21,7 +21,7 @@ build() {
check() {
cd $_name-$pkgver
- pytest -v
+ python setup.py test
}
package() {