summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-01-14 01:08:03 +0800
committerUniversebenzene2019-01-14 01:08:03 +0800
commit2ed6d4432fe54c3815660c9453647c0579ee0b90 (patch)
tree5d3b27677414ae7cf2909b207e58061e0adea185
parent184bc948f241bf87c52abbf123a6054c4d85d139 (diff)
downloadaur-2ed6d4432fe54c3815660c9453647c0579ee0b90.tar.gz
Update to version 1.7.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0f43e3893a..5ad845bead5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 10 17:45:57 UTC 2019
+# Sun Jan 13 17:07:15 UTC 2019
pkgbase = python-soupsieve
pkgdesc = A modern CSS selector implementation for BeautifulSoup
- pkgver = 1.7
+ pkgver = 1.7.1
pkgrel = 1
url = https://facelessuser.github.io/soupsieve/
arch = i686
@@ -14,16 +14,15 @@ pkgbase = python-soupsieve
checkdepends = python-beautifulsoup4
checkdepends = python2-html5lib
checkdepends = python-html5lib
+ checkdepends = python2-backports.functools_lru_cache
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/s/soupsieve/soupsieve-1.7.tar.gz
- md5sums = 2b5a9f36b55ab1b0c079e07e9926da82
+ source = https://files.pythonhosted.org/packages/source/s/soupsieve/soupsieve-1.7.1.tar.gz
+ md5sums = 92a40c3a664175949622e311cf0779bb
pkgname = python-soupsieve
depends = python>=3.4
- depends = python-beautifulsoup4
pkgname = python2-soupsieve
depends = python2>=2.7
- depends = python2-beautifulsoup4
diff --git a/PKGBUILD b/PKGBUILD
index 561b020239b..310f57f39a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgbase=python-soupsieve
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}")
-pkgver=1.7
+pkgver=1.7.1
pkgrel=1
pkgdesc="A modern CSS selector implementation for BeautifulSoup"
arch=('i686' 'x86_64')
url="https://facelessuser.github.io/soupsieve/"
license=('MIT')
makedepends=('python-setuptools' 'python2-setuptools')
-checkdepends=('python-pytest' 'python2-pytest' 'python2-beautifulsoup4' 'python-beautifulsoup4' 'python2-html5lib' 'python-html5lib')
+checkdepends=('python-pytest' 'python2-pytest' 'python2-beautifulsoup4' 'python-beautifulsoup4' 'python2-html5lib' 'python-html5lib' 'python2-backports.functools_lru_cache')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('2b5a9f36b55ab1b0c079e07e9926da82')
+md5sums=('92a40c3a664175949622e311cf0779bb')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -40,7 +40,7 @@ check() {
}
package_python2-soupsieve() {
- depends=('python2>=2.7' 'python2-beautifulsoup4')
+ depends=('python2>=2.7')
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
@@ -49,7 +49,7 @@ package_python2-soupsieve() {
}
package_python-soupsieve() {
- depends=('python>=3.4' 'python-beautifulsoup4')
+ depends=('python>=3.4')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"