summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-09-28 22:47:56 +0200
committerPhilip Goto2020-09-28 22:47:56 +0200
commit84fdfb27b81e273a10b9c3a8867c05c49f1604de (patch)
tree4c06ea46015e56fd1456553b25bbb14de4acabfe
parent99e15fc51ee1f1be23da1b93972f3e118df9d958 (diff)
downloadaur-84fdfb27b81e273a10b9c3a8867c05c49f1604de.tar.gz
Update to 2.3.2
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD63
2 files changed, 48 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 023dc2d15f79..e6e30d9f1050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,31 @@
pkgbase = python-spacy
- pkgdesc = A free open-source library for Natural Language Processing in Python
- pkgver = 2.2.4
+ pkgdesc = Free open-source library for Natural Language Processing in Python
+ pkgver = 2.3.2
pkgrel = 1
url = https://spacy.io/
+ arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = MIT
makedepends = python-wheel
makedepends = cython
- depends = python-numpy
+ depends = python-catalogue
depends = python-cymem
- depends = python-preshed
- depends = python-thinc
depends = python-murmurhash
+ depends = python-numpy
+ depends = python-pathlib
depends = python-plac
- depends = python-ujson
+ depends = python-preshed
depends = python-regex
depends = python-requests
- depends = python-pathlib
depends = python-srsly
- depends = python-wasabi
- depends = python-catalogue
- depends = python-plac
+ depends = python-thinc
depends = python-tqdm
- optdepends = python-mock: run included tests
- optdepends = python-pytest: run included tests
- optdepends = flake8: linting for Python code
- source = python-spacy-2.2.4.tar.gz::https://github.com/explosion/spaCy/archive/v2.2.4.tar.gz
- md5sums = 0e0986ce7fd3db3b7163095d47514e89
+ depends = python-ujson
+ depends = python-wasabi
+ source = https://files.pythonhosted.org/packages/18/db/499f374339b522b6618234b93f25d2990692795ccce3152519ccc508586c/spacy-2.3.2.tar.gz
+ sha256sums = 818de26e0e383f64ccbe3db185574920de05923d8deac8bbb12113b9e33cee1f
pkgname = python-spacy
diff --git a/PKGBUILD b/PKGBUILD
index 87e76778f871..0b17239ce45c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
-# Maintainer: Chris Brendel <cdbrendel@gmail.com>
-# Python package author: Matthew Honnibal <matt@explosion.ai>
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Chris Brendel <cdbrendel@gmail.com>
+
pkgname=python-spacy
-_origpkgname=spaCy
-pkgver=2.2.4
+pkgver=2.3.2
pkgrel=1
-pkgdesc="A free open-source library for Natural Language Processing in Python"
-arch=("x86_64")
+pkgdesc="Free open-source library for Natural Language Processing in Python"
+arch=(i686 x86_64 armv7h aarch64)
url="https://spacy.io/"
-license=("MIT")
-depends=("python-numpy"
- "python-cymem"
- "python-preshed"
- "python-thinc"
- "python-murmurhash"
- "python-plac"
- "python-ujson"
- "python-regex"
- "python-requests"
- "python-pathlib"
- "python-srsly"
- "python-wasabi"
- "python-catalogue"
- "python-plac"
- "python-tqdm"
+license=(MIT)
+depends=(
+ python-catalogue
+ python-cymem
+ python-murmurhash
+ python-numpy
+ python-pathlib
+ python-plac
+ python-preshed
+ python-regex
+ python-requests
+ python-srsly
+ python-thinc
+ python-tqdm
+ python-ujson
+ python-wasabi
)
-makedepends=("python-wheel" "cython")
-optdepends=("python-mock: run included tests" "python-pytest: run included tests" "flake8: linting for Python code" )
-source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/spaCy/archive/v$pkgver.tar.gz")
-md5sums=('0e0986ce7fd3db3b7163095d47514e89')
+makedepends=(python-wheel cython)
+source=("https://files.pythonhosted.org/packages/18/db/499f374339b522b6618234b93f25d2990692795ccce3152519ccc508586c/spacy-2.3.2.tar.gz")
+sha256sums=('818de26e0e383f64ccbe3db185574920de05923d8deac8bbb12113b9e33cee1f')
+
+
+build() {
+ cd "spacy-${pkgver}"
+ python setup.py build
+}
package() {
- cd "$_origpkgname-$pkgver"
- python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "spacy-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}