summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Brendel2020-05-03 20:27:40 -0700
committerChris Brendel2020-05-03 20:27:40 -0700
commit99e15fc51ee1f1be23da1b93972f3e118df9d958 (patch)
tree990da9ef316cf13fee57abb26f7298c319d36456
parentee290eeb65d37336c5a8c90188115e45caa2cd7b (diff)
downloadaur-99e15fc51ee1f1be23da1b93972f3e118df9d958.tar.gz
updated to version 2.2.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991e940cc952..023dc2d15f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-spacy
pkgdesc = A free open-source library for Natural Language Processing in Python
- pkgver = 2.2.3
+ pkgver = 2.2.4
pkgrel = 1
url = https://spacy.io/
arch = x86_64
license = MIT
makedepends = python-wheel
- depends = cython
+ makedepends = cython
depends = python-numpy
depends = python-cymem
depends = python-preshed
@@ -16,14 +16,17 @@ pkgbase = python-spacy
depends = python-ujson
depends = python-regex
depends = python-requests
- depends = python-pytest
- depends = python-mock
depends = python-pathlib
- depends = python-srsly-git
- depends = python-wasabi-git
+ depends = python-srsly
+ depends = python-wasabi
depends = python-catalogue
- source = python-spacy-2.2.3.tar.gz::https://github.com/explosion/spaCy/archive/v2.2.3.tar.gz
- md5sums = 0e4d0f81a3db589fde7d476ddbf93c9e
+ depends = python-plac
+ depends = python-tqdm
+ optdepends = python-mock: run included tests
+ optdepends = python-pytest: run included tests
+ optdepends = flake8: linting for Python code
+ source = python-spacy-2.2.4.tar.gz::https://github.com/explosion/spaCy/archive/v2.2.4.tar.gz
+ md5sums = 0e0986ce7fd3db3b7163095d47514e89
pkgname = python-spacy
diff --git a/PKGBUILD b/PKGBUILD
index c3cb2a2878f1..87e76778f871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Python package author: Matthew Honnibal <matt@explosion.ai>
pkgname=python-spacy
_origpkgname=spaCy
-pkgver=2.2.3
+pkgver=2.2.4
pkgrel=1
pkgdesc="A free open-source library for Natural Language Processing in Python"
arch=("x86_64")
url="https://spacy.io/"
license=("MIT")
-depends=("cython"
- "python-numpy"
+depends=("python-numpy"
"python-cymem"
"python-preshed"
"python-thinc"
@@ -18,16 +17,17 @@ depends=("cython"
"python-ujson"
"python-regex"
"python-requests"
- "python-pytest"
- "python-mock"
"python-pathlib"
- "python-srsly-git"
- "python-wasabi-git"
+ "python-srsly"
+ "python-wasabi"
"python-catalogue"
+ "python-plac"
+ "python-tqdm"
)
-makedepends=("python-wheel")
+makedepends=("python-wheel" "cython")
+optdepends=("python-mock: run included tests" "python-pytest: run included tests" "flake8: linting for Python code" )
source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/spaCy/archive/v$pkgver.tar.gz")
-md5sums=('0e4d0f81a3db589fde7d476ddbf93c9e')
+md5sums=('0e0986ce7fd3db3b7163095d47514e89')
package() {
cd "$_origpkgname-$pkgver"