summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2022-07-18 18:17:17 +0200
committerPhilip Goto2022-07-18 18:17:17 +0200
commitd5cf6c4e5e52f61dd83ec733d2acefe05e6dd876 (patch)
tree0bccb19c60e8879e0e0d3e254338dbd56141ee8f
parent9393877f684fb6e44efcae2c50bec43318b4483b (diff)
downloadaur-d5cf6c4e5e52f61dd83ec733d2acefe05e6dd876.tar.gz
Update to 3.4.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 602aa549d22c..48ea803789a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-spacy
pkgdesc = Free open-source library for Natural Language Processing in Python
- pkgver = 3.3.1
+ pkgver = 3.4.0
pkgrel = 1
url = https://spacy.io/
arch = x86_64
arch = aarch64
license = MIT
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-wheel
makedepends = cython
depends = python-catalogue
@@ -25,7 +26,7 @@ pkgbase = python-spacy
depends = python-typer
depends = python-ujson
depends = python-wasabi
- source = https://files.pythonhosted.org/packages/source/s/spacy/spacy-3.3.1.tar.gz
- b2sums = 0a2860392f4e0f5c3ec2ab005a68faea374ff3726994734aefff4a2c44ad3bea541a94411a4b4100a156513469170c6c68337fc31673332e0c963a90824542cf
+ source = https://files.pythonhosted.org/packages/source/s/spacy/spacy-3.4.0.tar.gz
+ b2sums = 9b4b9e42767a7054a3dbd22c3824752cd1fddec3f432890a7ab659a7999ce1db6833c001352c1d65184ffc496347844c5dd7cc5fc019c2ad15919a0c6c04859e
pkgname = python-spacy
diff --git a/PKGBUILD b/PKGBUILD
index 3ad3c29a43b5..3208c6c8a584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=spacy
pkgname=python-${_pkgname}
-pkgver=3.3.1
+pkgver=3.4.0
pkgrel=1
pkgdesc='Free open-source library for Natural Language Processing in Python'
arch=(x86_64 aarch64)
@@ -28,20 +28,21 @@ depends=(
python-wasabi
)
makedepends=(
- python-pip
+ python-build
+ python-installer
python-wheel
cython
)
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-b2sums=('0a2860392f4e0f5c3ec2ab005a68faea374ff3726994734aefff4a2c44ad3bea541a94411a4b4100a156513469170c6c68337fc31673332e0c963a90824542cf')
+b2sums=('9b4b9e42767a7054a3dbd22c3824752cd1fddec3f432890a7ab659a7999ce1db6833c001352c1d65184ffc496347844c5dd7cc5fc019c2ad15919a0c6c04859e')
build() {
cd "spacy-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation --skip-dependency-check
}
package() {
cd "spacy-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}