summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2022-05-03 08:49:56 +0200
committerJ. Nathanael Philipp2022-05-03 08:49:56 +0200
commit991dad03167ff521c151b31ec67f824414d7bd33 (patch)
tree89fada469f33bf71f6a59c82e18447073605e045
downloadaur-991dad03167ff521c151b31ec67f824414d7bd33.tar.gz
Init.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84d1a6b81542
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-spacy-alignments
+ pkgdesc = A spaCy package for the Rust tokenizations library
+ pkgver = 0.8.5
+ pkgrel = 1
+ url = https://github.com/explosion/spacy-alignments
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = python-pip
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ makedepends = python-setuptools-rust
+ depends = python-hypothesis
+ source = https://raw.githubusercontent.com/explosion/spacy-alignments/master/LICENSE
+ source = https://github.com/explosion/spacy-alignments/archive/refs/tags/v0.8.5.zip
+ b2sums = 2aa37d0c1171ddc760676a38def395e1968478908ea56edf4f014df68e096465cc86fa333e47f914828c662bd9a62a9e0d2d99f7b78fdeddbde19f00a4bffef3
+ b2sums = 31acc23166cf0a805171379518fd1bc35cc8a2064599a59e64117326767f6488583f4d0d3b4aabdfa287bfcc7d752c1e3e3a619f3988bdc128e7a3f45e0080d4
+
+pkgname = python-spacy-alignments
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f45c08c68ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: J. Nathanael Philipp (jnphilipp) <nathanael@philipp.land>
+
+_pkgname=spacy-alignments
+pkgname=python-${_pkgname}
+pkgver=0.8.5
+pkgrel=1
+pkgdesc="A spaCy package for the Rust tokenizations library"
+arch=(x86_64 aarch64)
+url="https://github.com/explosion/spacy-alignments"
+license=(MIT)
+depends=(python-hypothesis)
+makedepends=(
+ python-pip
+ python-wheel
+ python-setuptools
+ python-setuptools-rust
+)
+source=(
+ "https://raw.githubusercontent.com/explosion/spacy-alignments/master/LICENSE"
+ "https://github.com/explosion/${_pkgname}/archive/refs/tags/v${pkgver}.zip"
+)
+b2sums=(
+ "2aa37d0c1171ddc760676a38def395e1968478908ea56edf4f014df68e096465cc86fa333e47f914828c662bd9a62a9e0d2d99f7b78fdeddbde19f00a4bffef3"
+ "31acc23166cf0a805171379518fd1bc35cc8a2064599a59e64117326767f6488583f4d0d3b4aabdfa287bfcc7d752c1e3e3a619f3988bdc128e7a3f45e0080d4"
+)
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ #python setup.py build
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ #python setup.py install --skip-build --prefix=/usr --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}