summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2020-09-10 00:19:09 +0200
committerJ. Nathanael Philipp2020-09-10 00:19:09 +0200
commit43d7be1a22b1940de588f8860932e543a4d68372 (patch)
treea33231b4af31ee4f592d81dd1d8149de7ea8afac
downloadaur-43d7be1a22b1940de588f8860932e543a4d68372.tar.gz
Init.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..756137a23e4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-spacy-de_core_news_lg
+ pkgdesc = German multi-task CNN trained on the TIGER and WikiNER corpora. Assigns word vectors, POS tags, dependency parses and named entities. Word vectors trained using FastText CBOW on Wikipedia and OSCAR (Common Crawl).
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://spacy.io/models/de#de_core_news_lg
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-spacy
+ source = https://github.com/explosion/spacy-models/releases/download/de_core_news_lg-2.3.0/de_core_news_lg-2.3.0.tar.gz
+ sha256sums = cd3c565cfb6dd3df535b109077466685986059b18387259cc1fa7cf2db833d66
+
+pkgname = python-spacy-de_core_news_lg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e635630c4b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: J. Nathanael Philipp (jnphilipp) <nathanael@philipp.land>
+
+pkgname=python-spacy-de_core_news_lg
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="German multi-task CNN trained on the TIGER and WikiNER corpora. Assigns word vectors, POS tags, dependency parses and named entities. Word vectors trained using FastText CBOW on Wikipedia and OSCAR (Common Crawl)."
+url="https://spacy.io/models/de#de_core_news_lg"
+depends=('python-spacy')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=(any)
+source=("https://github.com/explosion/spacy-models/releases/download/de_core_news_lg-${pkgver}/de_core_news_lg-${pkgver}.tar.gz")
+sha256sums=('cd3c565cfb6dd3df535b109077466685986059b18387259cc1fa7cf2db833d66')
+
+build() {
+ cd de_core_news_lg-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd de_core_news_lg-${pkgver}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}