summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2020-09-10 00:17:02 +0200
committerJ. Nathanael Philipp2020-09-10 00:17:02 +0200
commitf374af734679875e412128681b6d088262f5ca2c (patch)
treef28860bd326b898f30c095150418bbbc034a1d2f
downloadaur-f374af734679875e412128681b6d088262f5ca2c.tar.gz
Init.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9073f356cc44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-spacy-de_core_news_md
+ pkgdesc = German multi-task CNN trained on the TIGER and WikiNER corpora. Assigns word vectors, POS tags, dependency parses and named entities. Word vectors trained using FastText CBOW on Wikipedia and OSCAR (Common Crawl).
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://spacy.io/models/de#de_core_news_md
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-spacy
+ source = https://github.com/explosion/spacy-models/releases/download/de_core_news_md-2.3.0/de_core_news_md-2.3.0.tar.gz
+ sha256sums = 2636294e1e9351cca312a88659859d367684cca968a83b837525030078c8b14f
+
+pkgname = python-spacy-de_core_news_md
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d24c4b2ce3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: J. Nathanael Philipp (jnphilipp) <nathanael@philipp.land>
+
+pkgname=python-spacy-de_core_news_md
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="German multi-task CNN trained on the TIGER and WikiNER corpora. Assigns word vectors, POS tags, dependency parses and named entities. Word vectors trained using FastText CBOW on Wikipedia and OSCAR (Common Crawl)."
+url="https://spacy.io/models/de#de_core_news_md"
+depends=('python-spacy')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=(any)
+source=("https://github.com/explosion/spacy-models/releases/download/de_core_news_md-${pkgver}/de_core_news_md-${pkgver}.tar.gz")
+sha256sums=('2636294e1e9351cca312a88659859d367684cca968a83b837525030078c8b14f')
+
+build() {
+ cd de_core_news_md-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd de_core_news_md-${pkgver}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}