summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-03-09 22:42:34 +0100
committerPhilip Goto2019-03-09 22:42:34 +0100
commit45e9b612f6f5c19887ded1e11d048f9f1f6267d7 (patch)
tree23a491e765d7712ce1f33a2b919bd5d3b7c5dfa3
downloadaur-45e9b612f6f5c19887ded1e11d048f9f1f6267d7.tar.gz
Initialize package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fed7349b7547
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-spacy-es_core_news_sm
+ pkgdesc = Spanish multi-task CNN trained on the AnCora and WikiNER corpus for spaCy
+ pkgver = 2.1.0a7
+ pkgrel = 1
+ url = https://spacy.io/models/en#section-en_core_web_sm
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ source = https://github.com/explosion/spacy-models/releases/download/es_core_news_sm-2.1.0a7/es_core_news_sm-2.1.0a7.tar.gz
+ sha256sums = 635634edbb74e07e41be0c7308e7cc3735aa3c11d4796dd3a2573b74d98116cd
+
+pkgname = python-spacy-es_core_news_sm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..208dceddc035
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-spacy-es_core_news_sm
+pkgver=2.1.0a7
+pkgrel=1
+pkgdesc="Spanish multi-task CNN trained on the AnCora and WikiNER corpus for spaCy"
+url="https://spacy.io/models/en#section-en_core_web_sm"
+makedepends=('python-setuptools')
+license=('GPL')
+arch=(any)
+source=("https://github.com/explosion/spacy-models/releases/download/es_core_news_sm-${pkgver}/es_core_news_sm-${pkgver}.tar.gz")
+sha256sums=('635634edbb74e07e41be0c7308e7cc3735aa3c11d4796dd3a2573b74d98116cd')
+
+build() {
+ cd es_core_news_sm-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd es_core_news_sm-${pkgver}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}