summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-21 23:30:15 -0500
committerDanManN2018-12-21 23:30:15 -0500
commit4682f109e72143ec5aa27892b53f07d33d7b1aac (patch)
treebcc9cb43c90cc13741068cbe3aa4be1358813fdb
parentdff43e0fba3a3346399f39d13549c1ffaf57b18f (diff)
downloadaur-4682f109e72143ec5aa27892b53f07d33d7b1aac.tar.gz
new deps
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 34 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e52b53cb1cbd..4b3be66a791a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,30 @@
pkgbase = python-spacy-git
pkgdesc = A free open-source library for Natural Language Processing in Python
- pkgver = 2.0.18.r8886.bbaca991
- pkgrel = 3
+ pkgver = 2.1.0a4.r9320.0f83b98a
+ pkgrel = 4
url = https://spacy.io/
arch = x86_64
license = MIT
makedepends = git
makedepends = python-setuptools
makedepends = python-wheel
- depends = cython
- depends = python-numpy
depends = python-cymem
depends = python-preshed
depends = python-thinc
+ depends = python-blis
depends = python-murmurhash
- depends = python-plac
- depends = python-ujson
- depends = python-dill
- depends = python-regex
+ depends = python-wasabi
+ depends = python-srsly
+ depends = python-numpy
depends = python-requests
+ depends = python-jsonschema
+ depends = python-regex
+ depends = python-plac
+ depends = cython
depends = python-pytest
+ depends = python-pytest-timeout
depends = python-mock
+ depends = flake8
provides = python-spacy
conflicts = python-spacy
source = git+https://github.com/explosion/spaCy.git
diff --git a/PKGBUILD b/PKGBUILD
index b64e7edf0ab1..03e5a59aeab8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,31 @@
# Python package author: Matthew Honnibal <matt@explosion.ai>
pkgname=python-spacy-git
_origpkgname=spaCy
-pkgver=2.0.18.r8886.bbaca991
-pkgrel=3
+pkgver=2.1.0a4.r9320.0f83b98a
+pkgrel=4
pkgdesc="A free open-source library for Natural Language Processing in Python"
arch=("x86_64")
url="https://spacy.io/"
license=("MIT")
-depends=("cython"
- "python-numpy"
- "python-cymem"
- "python-preshed"
- "python-thinc"
- "python-murmurhash"
- "python-plac"
- "python-ujson"
- "python-dill"
- "python-regex"
- "python-requests"
- "python-pytest"
- "python-mock"
-)
+depends=("python-cymem"
+ "python-preshed"
+ "python-thinc"
+ "python-blis"
+ "python-murmurhash"
+ "python-wasabi"
+ "python-srsly"
+ "python-numpy"
+ "python-requests"
+ "python-jsonschema"
+ "python-regex"
+ "python-plac"
+ "cython"
+ "python-pytest"
+ "python-pytest-timeout"
+ "python-mock"
+ "flake8"
+ )
+
makedepends=('git' 'python-setuptools' 'python-wheel')
provides=('python-spacy')
conflicts=('python-spacy')
@@ -35,7 +40,7 @@ prepare() {
pkgver() {
cd "$_origpkgname"
- printf "%s.r%s.%s" "$(cat spacy/about.py | grep -i version | grep -v '#' | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "$(cat spacy/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {