summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-12-09 22:06:03 +0100
committerPhilip Goto2018-12-09 22:07:51 +0100
commitc846b8dc810f4b23f42ba718b5904f84f958a38c (patch)
tree1f7c4edbb0978ea8b94affd2946c8a950b0a3616
downloadaur-c846b8dc810f4b23f42ba718b5904f84f958a38c.tar.gz
Initialize package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad287c37e411
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-spacy-nl_core_news_sm
+ pkgdesc = Dutch multi-task CNN trained on the Universal Dependencies and WikiNER corpus for spaCy
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://spacy.io/models/nl#section-nl_core_news_sm
+ arch = any
+ makedepends = python-setuptools
+ source = https://github.com/explosion/spacy-models/releases/download/nl_core_news_sm-2.0.0/nl_core_news_sm-2.0.0.tar.gz
+ sha256sums = 1f79eedcb397f9bfdce88b771369ba576664daba111411e750bd65746530bd58
+
+pkgname = python-spacy-nl_core_news_sm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b97017e175b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-spacy-nl_core_news_sm
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Dutch multi-task CNN trained on the Universal Dependencies and WikiNER corpus for spaCy"
+url="https://spacy.io/models/nl#section-nl_core_news_sm"
+makedepends=('python-setuptools')
+license=()
+arch=(any)
+source=("https://github.com/explosion/spacy-models/releases/download/nl_core_news_sm-${pkgver}/nl_core_news_sm-${pkgver}.tar.gz")
+sha256sums=('1f79eedcb397f9bfdce88b771369ba576664daba111411e750bd65746530bd58')
+
+build(){
+ cd nl_core_news_sm-${pkgver}
+ python setup.py build
+}
+
+package(){
+ cd nl_core_news_sm-${pkgver}
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}