summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-03-09 22:46:16 +0100
committerPhilip Goto2019-03-09 22:46:16 +0100
commit2018cae42d5df5b64e500ed3aef62855a48ffca7 (patch)
tree70abf0f5f6fcd67c13d58cd763463a7560b87fe1
downloadaur-2018cae42d5df5b64e500ed3aef62855a48ffca7.tar.gz
Initialize package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5208a6056bd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-spacy-xx_ent_wiki_sm
+ pkgdesc = English multi-task CNN trained on OntoNotes, with GloVe vectors trained on Common Crawl for spaCy
+ pkgver = 2.1.0a7
+ pkgrel = 1
+ url = https://spacy.io/models/xx#section-xx_ent_wiki_sm
+ arch = any
+ license = CCPL
+ makedepends = python-setuptools
+ source = https://github.com/explosion/spacy-models/releases/download/xx_ent_wiki_sm-2.1.0a7/xx_ent_wiki_sm-2.1.0a7.tar.gz
+ sha256sums = 1d07e7a7acbc1750c680c687725eabc836f094b8eeaf1a1b7c7901d5e4b67fdc
+
+pkgname = python-spacy-xx_ent_wiki_sm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe04410ecae8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-spacy-xx_ent_wiki_sm
+pkgver=2.1.0a7
+pkgrel=1
+pkgdesc="English multi-task CNN trained on OntoNotes, with GloVe vectors trained on Common Crawl for spaCy"
+url="https://spacy.io/models/xx#section-xx_ent_wiki_sm"
+makedepends=('python-setuptools')
+license=('CCPL')
+arch=(any)
+source=("https://github.com/explosion/spacy-models/releases/download/xx_ent_wiki_sm-${pkgver}/xx_ent_wiki_sm-${pkgver}.tar.gz")
+sha256sums=('1d07e7a7acbc1750c680c687725eabc836f094b8eeaf1a1b7c7901d5e4b67fdc')
+
+build() {
+ cd xx_ent_wiki_sm-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd xx_ent_wiki_sm-${pkgver}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}