summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-05-13 18:35:13 -0400
committerGuillaume Horel2017-05-13 18:35:13 -0400
commit989e6058caf24f880a4b18e3f79fa02f2dbc40dd (patch)
treead66ee45769c141510d990834e6b0197eb4d17ad
downloadaur-989e6058caf24f880a4b18e3f79fa02f2dbc40dd.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20da8c665793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-sparse
+ pkgdesc = Sparse multidimensional arrays on top of numpy and scipy
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mrocklin/sparse
+ arch = any
+ license = BSD
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ source = https://github.com/mrocklin/sparse/archive/0.1.0.tar.gz
+ sha256sums = 64e87e328c3c4b02317390aa051647b9c37f4bc1d09d6e53d89fc39173896a56
+
+pkgname = python-sparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf74890db670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=python-sparse
+_pkgname=sparse
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Sparse multidimensional arrays on top of numpy and scipy"
+arch=('any')
+url="https://github.com/mrocklin/sparse"
+license=('BSD')
+depends=('python' 'python-numpy' 'python-scipy')
+checkdepends=('python-pytest')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://github.com/mrocklin/sparse/archive/$pkgver.tar.gz")
+sha256sums=('64e87e328c3c4b02317390aa051647b9c37f4bc1d09d6e53d89fc39173896a56')
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+check(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ PYTHONPATH=. py.test
+}
+# vim:ts=2:sw=2:et: