summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJochem Broekhoff2020-10-23 20:29:51 +0200
committerJochem Broekhoff2020-10-23 20:29:51 +0200
commit6a0dd36ba24f68986eee2db47d5084e2e7719328 (patch)
tree920dd6a55cad26736f6126f9b7b7b831c5a8eff9
downloadaur-6a0dd36ba24f68986eee2db47d5084e2e7719328.tar.gz
Initial commit, version 0.6.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a4d0a0d3d3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-speech-features
+ pkgdesc = Python Speech Feature extraction
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/jameslyons/python_speech_features
+ arch = any
+ license = MIT
+ depends = python-scipy
+ depends = python-numpy
+ source = https://github.com/jameslyons/python_speech_features/archive/0.6.1.zip
+ sha256sums = 30ed2034fb26bc83b2b4a527a4fc45323c5a7674be0ac304f22559acfdb84e37
+
+pkgname = python-speech-features
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77681ee20bc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jochem Broekhoff <(lastname) dot (firstname) @ gmail.com>
+_pkgname=python_speech_features
+pkgname=python-speech-features
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Python Speech Feature extraction"
+arch=('any')
+license=('MIT')
+url="https://github.com/jameslyons/${_pkgname}"
+
+depends=("python-scipy"
+ "python-numpy")
+
+source=("https://github.com/jameslyons/${_pkgname}/archive/${pkgver}.zip")
+sha256sums=("30ed2034fb26bc83b2b4a527a4fc45323c5a7674be0ac304f22559acfdb84e37")
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}