summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2020-02-01 14:45:29 -0300
committerRenato Lui Geh2020-02-01 14:45:29 -0300
commit3f9e5575ffb51298f91410a71891b3a0fa9be4f9 (patch)
tree96937280f71c1a102cfedaa7a229b2fde777a209
parent77e6c0d1ff5d57462152146151d24b781d508ecc (diff)
downloadaur-3f9e5575ffb51298f91410a71891b3a0fa9be4f9.tar.gz
Add dependencies and check
Signed-off-by: Renato Lui Geh <renatogeh@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dff3873f7a33..aa354d1edec0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-spflow
pkgdesc = Sum-Product Flow: An Easy and Extensible Library for Sum-Product Networks
pkgver = 0.0.39
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SPFlow/SPFlow
arch = any
license = Apache 2.0
@@ -21,6 +21,10 @@ pkgbase = python-spflow
depends = python-pytest
depends = python-ete
depends = python-arff
+ depends = python-torchvision
+ depends = python-tensorflow-cuda
+ depends = python-pytorch-cuda
+ depends = cppyy
source = https://files.pythonhosted.org/packages/76/49/6b37eaa9bf8c758b99c3f297b39d81bdc5b07329ac674659d67f56493ead/spflow-0.0.39.tar.gz
sha256sums = a32a237c4ca01742a5dc4cf5ef895423d8275df8d9fac43f3e44e19ee1931a6e
diff --git a/PKGBUILD b/PKGBUILD
index f27a90be6cf4..358db590d10c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,25 @@
pkgname=python-spflow
_pypiname=${pkgname/python-/}
pkgver=0.0.39
-pkgrel=1
+pkgrel=2
pkgdesc="Sum-Product Flow: An Easy and Extensible Library for Sum-Product Networks"
arch=('any')
url="https://github.com/SPFlow/SPFlow"
license=('Apache 2.0')
depends=('python' 'python-numpy' 'python-scipy' 'python-statsmodels' 'python-networkx'
'python-joblib' 'python-matplotlib' 'python-pydot' 'python-lark-parser' 'python-tqdm'
- 'python-sympy' 'python-pyqt5' 'python-pytest' 'python-ete' 'python-arff')
+ 'python-sympy' 'python-pyqt5' 'python-pytest' 'python-ete' 'python-arff' 'python-torchvision'
+ 'python-tensorflow-cuda' 'python-pytorch-cuda' 'cppyy')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/76/49/6b37eaa9bf8c758b99c3f297b39d81bdc5b07329ac674659d67f56493ead/${_pypiname}-${pkgver}.tar.gz")
sha256sums=('a32a237c4ca01742a5dc4cf5ef895423d8275df8d9fac43f3e44e19ee1931a6e')
build() {
- cd $srcdir/${_pypiname}-${pkgver}
+ cd $srcdir
+ # Pull README.md and requirements.txt from Git due to setup.py dependencies.
+ wget 'https://raw.githubusercontent.com/SPFlow/SPFlow/master/README.md'
+ wget 'https://raw.githubusercontent.com/SPFlow/SPFlow/master/requirements.txt'
+ cd ${_pypiname}-${pkgver}
python3 setup.py build
}
@@ -25,3 +30,7 @@ package() {
python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
+check() {
+ cd $srcdir/${_pypiname}-${pkgver}
+ pytest
+}