summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-02-22 14:51:36 +0800
committerUniversebenzene2019-02-22 14:51:36 +0800
commit1d5ffd753d9dcb26d4470192d0e856644cdf8c0d (patch)
treedf678cfbc9e2a95f91165a6843b065ab577dfed6
parent1bff62bfb25fc197bfae31272832311eacc53426 (diff)
downloadaur-1d5ffd753d9dcb26d4470192d0e856644cdf8c0d.tar.gz
Update to version 1.2.8
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD45
-rw-r--r--fix_doc_warning.patch20
-rw-r--r--fix_testing.patch21
-rw-r--r--spherical_geometry.patch31
5 files changed, 80 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d079e7428314..be92680d6b48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,31 @@
# Generated by mksrcinfo v8
-# Mon Dec 10 07:02:02 UTC 2018
+# Fri Feb 22 06:49:41 UTC 2019
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.5
- pkgrel = 2
+ pkgver = 1.2.8
+ pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
arch = x86_64
license = BSD
- makedepends = cython
+ checkdepends = python-pytest-astropy
+ makedepends = python-setuptools
makedepends = qd>=2.3.7
- makedepends = python-astropy>=3.0
+ makedepends = python-astropy>=3.1
makedepends = python-astropy-helpers>=3.1
- makedepends = python-sphinx
makedepends = python-sphinx-astropy
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.5.tar.gz
- source = spherical_geometry.patch
- md5sums = bf33af71561a69231c9d5e1238e557c5
- md5sums = bf3b812ddc47c2d8fcbfb2c3179fbc24
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.8.tar.gz
+ source = fix_doc_warning.patch
+ source = fix_testing.patch
+ md5sums = fba216fed5b504c8470b40afda5140a7
+ md5sums = a758662c8183e7769432aa1ad3691d49
+ md5sums = 56f626fd4602e44528f7ef2521dc17d6
pkgname = python-spherical_geometry
depends = python>=3.5
- depends = python-numpy>=1.5.0
+ depends = python-numpy>=1.10.0
depends = qd>=2.3.7
- depends = python-astropy>=0.3
+ depends = python-astropy>=0.4
optdepends = python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit
optdepends = python-pytest-astropy: For testing suite
diff --git a/PKGBUILD b/PKGBUILD
index bd349022ea47..34f5b625ec71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,49 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-spherical_geometry
-pkgname=('python-spherical_geometry' 'python-spherical_geometry-doc')
-pkgver=1.2.5
-pkgrel=2
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}" "python-${_pyname}-doc")
+pkgver=1.2.8
+pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
license=('BSD')
-makedepends=('cython' 'qd>=2.3.7' 'python-astropy>=3.0' 'python-astropy-helpers>=3.1' 'python-sphinx' 'python-sphinx-astropy')
-#checkdepends=('python-pytest-astropy')
-source=("https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-${pkgver}.tar.gz"
- 'spherical_geometry.patch')
-md5sums=('bf33af71561a69231c9d5e1238e557c5'
- 'bf3b812ddc47c2d8fcbfb2c3179fbc24')
+makedepends=('python-setuptools' 'qd>=2.3.7' 'python-astropy>=3.1' 'python-astropy-helpers>=3.1' 'python-sphinx-astropy')
+checkdepends=('python-pytest-astropy')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'fix_doc_warning.patch'
+ 'fix_testing.patch')
+md5sums=('fba216fed5b504c8470b40afda5140a7'
+ 'a758662c8183e7769432aa1ad3691d49'
+ '56f626fd4602e44528f7ef2521dc17d6')
prepare() {
- cd ${srcdir}/spherical_geometry-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
- patch -Np1 -i "${srcdir}/spherical_geometry.patch"
+ sed -i -e '/auto_use/s/True/False/' setup.cfg
+ patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
+ patch -Np1 -i "${srcdir}/fix_testing.patch"
}
build() {
- cd ${srcdir}/spherical_geometry-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build --use-system-libraries --offline
msg "Building Docs"
python setup.py build_docs
}
-#check() {
-# cd ${srcdir}/spherical_geometry-${pkgver}
-#
-# python setup.py test
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py test
+}
package_python-spherical_geometry() {
- depends=('python>=3.5' 'python-numpy>=1.5.0' 'qd>=2.3.7' 'python-astropy>=0.3')
+ depends=('python>=3.5' 'python-numpy>=1.10.0' 'qd>=2.3.7' 'python-astropy>=0.4')
optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit'
'python-pytest-astropy: For testing suite')
- cd ${srcdir}/spherical_geometry-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
@@ -48,7 +53,7 @@ package_python-spherical_geometry() {
package_python-spherical_geometry-doc() {
pkgdesc="Documentation for Python Spherical Geometry Toolkit"
- cd ${srcdir}/spherical_geometry-${pkgver}/docs/_build
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
diff --git a/fix_doc_warning.patch b/fix_doc_warning.patch
new file mode 100644
index 000000000000..4f102d5596b8
--- /dev/null
+++ b/fix_doc_warning.patch
@@ -0,0 +1,20 @@
+--- a/README.rst 2019-02-22 12:38:47.000000000 +0800
++++ b/README.rst 2019-02-22 14:08:11.909861996 +0800
+@@ -110,6 +110,8 @@
+ Disjoint Polygons
+ ^^^^^^^^^^^^^^^^^
+
++.. currentmodule:: spherical_geometry.polygon
++
+ If a polygon is the result of the intersection of polygons, it may be
+ disjoint. Disjoint polygons are represented as a list of spherical
+ polygons. The library handles the details of this internally. However,
+@@ -170,7 +172,7 @@
+ `~SphericalPolygon.multi_intersection`: Return a new polygon that
+ is the intersection of two or more polygons.
+
+- - `~SphericalPolygon.overlap`: Determine how much a given polygon
++ - `~SingleSphericalPolygon.overlap`: Determine how much a given polygon
+ overlaps another.
+
+ - `~SphericalPolygon.to_radec`: Convert (*x*, *y*, *z*) points in the
diff --git a/fix_testing.patch b/fix_testing.patch
new file mode 100644
index 000000000000..fa4989a5bb0d
--- /dev/null
+++ b/fix_testing.patch
@@ -0,0 +1,21 @@
+--- a/setup.cfg 2019-02-22 14:36:03.933684666 +0800
++++ b/setup.cfg 2019-02-22 14:36:33.284391606 +0800
+@@ -7,7 +7,7 @@
+ upload-dir = docs/_build/html
+ show-response = 1
+
+-[pytest]
++[tool:pytest]
+ minversion = 2.2
+ norecursedirs = .git build docs/_build
+
+--- a/spherical_geometry/polygon.py 2019-02-22 13:24:12.000000000 +0800
++++ b/spherical_geometry/polygon.py 2019-02-22 14:37:08.668576535 +0800
+@@ -270,6 +270,7 @@
+ -------
+ polygon : `SingleSphericalPolygon` object
+ """
++ import astropy
+ from astropy import wcs as pywcs
+ from astropy.io import fits
+
diff --git a/spherical_geometry.patch b/spherical_geometry.patch
deleted file mode 100644
index 716156e25eb5..000000000000
--- a/spherical_geometry.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/README.rst 2018-02-22 23:21:38.000000000 +0800
-+++ b/README.rst 2018-06-30 21:44:05.756359550 +0800
-@@ -102,6 +102,8 @@
- Disjoint Polygons
- ^^^^^^^^^^^^^^^^^
-
-+.. currentmodule:: spherical_geometry.polygon
-+
- If a polygon is the result of the intersection of polygons, it may be disjoint.
- Disjoint polygons are represented as a list of spherical polygons. The library
- handles the details of this internally. However, the user must be aware that
-@@ -156,7 +158,7 @@
- `~SphericalPolygon.multi_intersection`: Return a new polygon that
- is the intersection of two or more polygons.
-
-- - `~SphericalPolygon.overlap`: Determine how much a given polygon
-+ - `~SingleSphericalPolygon.overlap`: Determine how much a given polygon
- overlaps another.
-
- - `~SphericalPolygon.to_radec`: Convert (*x*, *y*, *z*) points in the
---- a/setup.cfg 2018-02-22 23:21:38.000000000 +0800
-+++ b/setup.cfg 2018-06-30 21:42:29.061892875 +0800
-@@ -12,7 +12,7 @@
- norecursedirs = .git build docs/_build
-
- [ah_bootstrap]
--auto_use = True
-+auto_use = False
-
- [metadata]
- package_name = spherical_geometry