summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-02-24 15:14:07 +0800
committerUniversebenzene2019-02-24 15:14:07 +0800
commit2332d2ace5868798e01da5670be4bcce16f51291 (patch)
tree3c0a5307898b6cee2db246d167e6a55e30d46889
parent8230d514e577d539ec035c8f4cf132212dc6979a (diff)
downloadaur-2332d2ace5868798e01da5670be4bcce16f51291.tar.gz
More fixing for doc building
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--fix_doc_warning.patch22
3 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d73c9e5f898c..c752ac9576e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Feb 22 16:53:04 UTC 2019
+# Sun Feb 24 07:13:05 UTC 2019
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
pkgver = 1.2.9
- pkgrel = 1
+ pkgrel = 2
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = python-spherical_geometry
source = fix_doc_warning.patch
source = fix_testing.patch
md5sums = 6c82d0d4b6510efd4b67318125d9d9b5
- md5sums = a758662c8183e7769432aa1ad3691d49
+ md5sums = 4cffeb20c8e88870eae7188104308a35
md5sums = e56ff23d07fe3ac32553b9f86b0433b8
pkgname = python-spherical_geometry
diff --git a/PKGBUILD b/PKGBUILD
index 0b8c06ad35b3..78ec4229fec3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-spherical_geometry
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
pkgver=1.2.9
-pkgrel=1
+pkgrel=2
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
@@ -14,7 +14,7 @@ source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname
'fix_doc_warning.patch'
'fix_testing.patch')
md5sums=('6c82d0d4b6510efd4b67318125d9d9b5'
- 'a758662c8183e7769432aa1ad3691d49'
+ '4cffeb20c8e88870eae7188104308a35'
'e56ff23d07fe3ac32553b9f86b0433b8')
prepare() {
diff --git a/fix_doc_warning.patch b/fix_doc_warning.patch
index 4f102d5596b8..378986c5129d 100644
--- a/fix_doc_warning.patch
+++ b/fix_doc_warning.patch
@@ -1,14 +1,22 @@
--- a/README.rst 2019-02-22 12:38:47.000000000 +0800
-+++ b/README.rst 2019-02-22 14:08:11.909861996 +0800
-@@ -110,6 +110,8 @@
- Disjoint Polygons
- ^^^^^^^^^^^^^^^^^
++++ b/README.rst 2019-02-24 15:06:53.785650230 +0800
+@@ -93,12 +93,14 @@
+ What is the orientation?
+ ^^^^^^^^^^^^^^^^^^^^^^^^
+.. currentmodule:: spherical_geometry.polygon
+
- If a polygon is the result of the intersection of polygons, it may be
- disjoint. Disjoint polygons are represented as a list of spherical
- polygons. The library handles the details of this internally. However,
+ The correctness of several of the algorithms using polygons depends on
+ a consistent orientation of the points defining it. That is, the points
+ should have a clockwise order. When creating a new spherical polygon,
+ the order of the points defining a polygon will be reversed if they are
+-not in clockwise order. The method `SphericalPolygon.is_clockwise`is
+-used to est if the points are in clockwise order. It takes two
++not in clockwise order. The method `SphericalPolygon.is_clockwise` is
++used to test if the points are in clockwise order. It takes two
+ successive sides and computes the normal vector to the sides. If the
+ normal vector points inward towards the center of the sphere, the two
+ sides are counter clockwise. If the normal vector points outward, the
@@ -170,7 +172,7 @@
`~SphericalPolygon.multi_intersection`: Return a new polygon that
is the intersection of two or more polygons.