summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-02-24 17:11:35 +0800
committerUniversebenzene2019-02-24 17:11:35 +0800
commit38b6ed8e4d6807b637995f6893b21350b9d2b5f7 (patch)
tree9b2fd3276bfce9ca8a0452029c8bea96136e2653
parent2332d2ace5868798e01da5670be4bcce16f51291 (diff)
downloadaur-38b6ed8e4d6807b637995f6893b21350b9d2b5f7.tar.gz
Change a patch into command line
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--fix_testing.patch11
3 files changed, 4 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c752ac9576e9..5fff58accc8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Feb 24 07:13:05 UTC 2019
+# Sun Feb 24 09:05:41 UTC 2019
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
pkgver = 1.2.9
@@ -16,10 +16,8 @@ pkgbase = python-spherical_geometry
makedepends = python-sphinx-astropy
source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.9.tar.gz
source = fix_doc_warning.patch
- source = fix_testing.patch
md5sums = 6c82d0d4b6510efd4b67318125d9d9b5
md5sums = 4cffeb20c8e88870eae7188104308a35
- md5sums = e56ff23d07fe3ac32553b9f86b0433b8
pkgname = python-spherical_geometry
depends = python>=3.5
diff --git a/PKGBUILD b/PKGBUILD
index 78ec4229fec3..7a80a2dcd203 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,18 +11,16 @@ license=('BSD')
makedepends=('python-setuptools' 'qd>=2.3.7' 'python-astropy>=3.1' 'python-astropy-helpers>=3.1' 'python-sphinx-astropy')
checkdepends=('python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- 'fix_doc_warning.patch'
- 'fix_testing.patch')
+ 'fix_doc_warning.patch')
md5sums=('6c82d0d4b6510efd4b67318125d9d9b5'
- '4cffeb20c8e88870eae7188104308a35'
- 'e56ff23d07fe3ac32553b9f86b0433b8')
+ '4cffeb20c8e88870eae7188104308a35')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
+ sed -i -e '/[pytest]/s/pytest/tool:pytest/' setup.cfg
sed -i -e '/auto_use/s/True/False/' setup.cfg
patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
- patch -Np1 -i "${srcdir}/fix_testing.patch"
}
build() {
diff --git a/fix_testing.patch b/fix_testing.patch
deleted file mode 100644
index d5716dee042d..000000000000
--- a/fix_testing.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/setup.cfg 2019-02-23 00:45:55.149040420 +0800
-+++ b/setup.cfg 2019-02-23 00:46:22.119762979 +0800
-@@ -7,7 +7,7 @@
- upload-dir = docs/_build/html
- show-response = 1
-
--[pytest]
-+[tool:pytest]
- minversion = 2.2
- norecursedirs = .git build docs/_build
-