summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-02-23 00:53:26 +0800
committerUniversebenzene2019-02-23 00:53:26 +0800
commit8230d514e577d539ec035c8f4cf132212dc6979a (patch)
tree75f64415c840bf40f759c97dbf904316fa1d56ea
parent1d5ffd753d9dcb26d4470192d0e856644cdf8c0d (diff)
downloadaur-8230d514e577d539ec035c8f4cf132212dc6979a.tar.gz
Update to version 1.2.9
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--fix_testing.patch14
3 files changed, 10 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be92680d6b48..d73c9e5f898c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 22 06:49:41 UTC 2019
+# Fri Feb 22 16:53:04 UTC 2019
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.8
+ pkgver = 1.2.9
pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
@@ -14,12 +14,12 @@ pkgbase = python-spherical_geometry
makedepends = python-astropy>=3.1
makedepends = python-astropy-helpers>=3.1
makedepends = python-sphinx-astropy
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.8.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.9.tar.gz
source = fix_doc_warning.patch
source = fix_testing.patch
- md5sums = fba216fed5b504c8470b40afda5140a7
+ md5sums = 6c82d0d4b6510efd4b67318125d9d9b5
md5sums = a758662c8183e7769432aa1ad3691d49
- md5sums = 56f626fd4602e44528f7ef2521dc17d6
+ md5sums = e56ff23d07fe3ac32553b9f86b0433b8
pkgname = python-spherical_geometry
depends = python>=3.5
diff --git a/PKGBUILD b/PKGBUILD
index 34f5b625ec71..0b8c06ad35b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-spherical_geometry
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.2.8
+pkgver=1.2.9
pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
@@ -13,9 +13,9 @@ checkdepends=('python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_doc_warning.patch'
'fix_testing.patch')
-md5sums=('fba216fed5b504c8470b40afda5140a7'
+md5sums=('6c82d0d4b6510efd4b67318125d9d9b5'
'a758662c8183e7769432aa1ad3691d49'
- '56f626fd4602e44528f7ef2521dc17d6')
+ 'e56ff23d07fe3ac32553b9f86b0433b8')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
diff --git a/fix_testing.patch b/fix_testing.patch
index fa4989a5bb0d..d5716dee042d 100644
--- a/fix_testing.patch
+++ b/fix_testing.patch
@@ -1,5 +1,5 @@
---- a/setup.cfg 2019-02-22 14:36:03.933684666 +0800
-+++ b/setup.cfg 2019-02-22 14:36:33.284391606 +0800
+--- a/setup.cfg 2019-02-23 00:45:55.149040420 +0800
++++ b/setup.cfg 2019-02-23 00:46:22.119762979 +0800
@@ -7,7 +7,7 @@
upload-dir = docs/_build/html
show-response = 1
@@ -9,13 +9,3 @@
minversion = 2.2
norecursedirs = .git build docs/_build
---- a/spherical_geometry/polygon.py 2019-02-22 13:24:12.000000000 +0800
-+++ b/spherical_geometry/polygon.py 2019-02-22 14:37:08.668576535 +0800
-@@ -270,6 +270,7 @@
- -------
- polygon : `SingleSphericalPolygon` object
- """
-+ import astropy
- from astropy import wcs as pywcs
- from astropy.io import fits
-