summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-05-06 16:45:08 +0800
committerUniversebenzene2018-05-06 16:45:08 +0800
commit9c278a041f78fb01078075c2c8fc94b13329761a (patch)
treeb88899429755f87a8147661a6c8d85d849784c7b
parent057dc5d8ceae58fe1e3fd3a5f088406f83f43872 (diff)
downloadaur-9c278a041f78fb01078075c2c8fc94b13329761a.tar.gz
Update to version 1.2.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--spherical_geometry.patch22
3 files changed, 47 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b745ebd3f24..9b7a9fc044b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
# Generated by mksrcinfo v8
-# Sun Feb 18 16:40:08 UTC 2018
+# Sun May 6 08:43:41 UTC 2018
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.1.0
- pkgrel = 3
+ pkgver = 1.2.2
+ pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
arch = x86_64
license = BSD
+ checkdepends = python-pytest-astropy
makedepends = cython
makedepends = qd>=2.3.7
- makedepends = python-astropy>=0.3
+ makedepends = python-astropy>=3.0
makedepends = python-astropy-helpers
makedepends = python-sphinx
makedepends = python-matplotlib
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.1.0.tar.gz
- md5sums = 83511d7d9ec2862f138e9e551432a544
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.2.tar.gz
+ source = spherical_geometry.patch
+ md5sums = 8559542cfceaac677d4de2dc8d0f7d69
+ md5sums = 3f0d22573ec591a015a120faf1854bef
pkgname = python-spherical_geometry
depends = python>=3.5
- depends = python-numpy>=1.5
+ depends = python-numpy>=1.5.0
depends = qd>=2.3.7
depends = python-astropy>=0.3
optdepends = python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit
diff --git a/PKGBUILD b/PKGBUILD
index b7c6a14b4193..1d9fc42488e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-spherical_geometry
pkgname=('python-spherical_geometry' 'python-spherical_geometry-doc')
-pkgver=1.1.0
-pkgrel=3
+pkgver=1.2.2
+pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
license=('BSD')
-makedepends=('cython' 'qd>=2.3.7' 'python-astropy>=0.3' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib')
-#checkdepends=('python-pytest')
-source=("https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-${pkgver}.tar.gz")
-md5sums=('83511d7d9ec2862f138e9e551432a544')
+makedepends=('cython' 'qd>=2.3.7' 'python-astropy>=3.0' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib')
+checkdepends=('python-pytest-astropy')
+source=("https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-${pkgver}.tar.gz"
+ 'spherical_geometry.patch')
+md5sums=('8559542cfceaac677d4de2dc8d0f7d69'
+ '3f0d22573ec591a015a120faf1854bef')
prepare() {
cd ${srcdir}/spherical_geometry-${pkgver}
- sed -i -e '/auto_use/s/True/False/' setup.cfg
+ patch -Np1 -i "${srcdir}/spherical_geometry.patch"
}
build () {
@@ -26,14 +28,14 @@ build () {
python setup.py build_docs
}
-#check(){
-# cd ${srcdir}/spherical_geometry-${pkgver}
-#
-# python setup.py test
-#}
+check(){
+ cd ${srcdir}/spherical_geometry-${pkgver}
+
+ python setup.py test
+}
package_python-spherical_geometry() {
- depends=('python>=3.5' 'python-numpy>=1.5' 'qd>=2.3.7' 'python-astropy>=0.3')
+ depends=('python>=3.5' 'python-numpy>=1.5.0' 'qd>=2.3.7' 'python-astropy>=0.3')
optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit')
cd ${srcdir}/spherical_geometry-${pkgver}
diff --git a/spherical_geometry.patch b/spherical_geometry.patch
new file mode 100644
index 000000000000..e519f713366a
--- /dev/null
+++ b/spherical_geometry.patch
@@ -0,0 +1,22 @@
+--- a/README.rst 2018-02-22 23:21:38.000000000 +0800
++++ b/README.rst 2018-05-06 16:14:13.548738696 +0800
+@@ -102,6 +102,8 @@
+ Disjoint Polygons
+ ^^^^^^^^^^^^^^^^^
+
++.. currentmodule:: spherical_geometry.polygon
++
+ If a polygon is the result of the intersection of polygons, it may be disjoint.
+ Disjoint polygons are represented as a list of spherical polygons. The library
+ handles the details of this internally. However, the user must be aware that
+--- a/setup.cfg 2018-02-22 23:21:38.000000000 +0800
++++ b/setup.cfg 2018-05-06 16:13:56.131595995 +0800
+@@ -12,7 +12,7 @@
+ norecursedirs = .git build docs/_build
+
+ [ah_bootstrap]
+-auto_use = True
++auto_use = False
+
+ [metadata]
+ package_name = spherical_geometry